summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2014-12-12 16:54:57 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2015-04-10 20:24:15 +0200
commitf80eef8f9ca04f923752efbda043ab856801be8a (patch)
treec584593f1f5e0c856f8a7adcc9eb94bfd2ebaaa9 /configure.ac
parent5b813b4340e9b2a8caafe55de4667caf9a4ce59d (diff)
downloadspice-f80eef8f9ca04f923752efbda043ab856801be8a.tar.gz
spice-f80eef8f9ca04f923752efbda043ab856801be8a.tar.xz
spice-f80eef8f9ca04f923752efbda043ab856801be8a.zip
build-sys: Replace cpu detection error with warning
configure.ac currently errors out when trying to build on non-x86/non-ARM CPUs. Since the previous commits improved big endian support a lot, this commit replaces the error with a warning at configure time to make testing on big endian platforms easier.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 7 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 6cf10bb5..7a9fc4bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,21 +61,12 @@ m4_ifndef([AS_VAR_APPEND],
AC_DEFUN([AS_VAR_APPEND], $1=$$1$2))
# Check for the CPU we are using
-#
-AC_MSG_CHECKING(for x86, x86-64 or armv6+ platform)
case $host_cpu in
- i386|i486|i586|i686|i786|k6|k7|armv6|armv6l|armv6hl|armv7|armv7l|armv7hl)
- variant=32
+ i386|i486|i586|i686|i786|k6|k7|x86_64|armv6|armv6l|armv6hl|armv7|armv7l|armv7hl)
;;
- x86_64)
- variant=64
- ;;
*)
- AC_MSG_RESULT(no)
- echo Only x86 and x86-64 are supported
- exit 1
+ arch_warn=1
esac
-AC_MSG_RESULT($variant bit)
dnl =========================================================================
dnl Check optional features
@@ -375,6 +366,11 @@ echo "
Manual: ${have_asciidoc}
"
+if test x"$arch_warn" = x1; then
+ AC_MSG_WARN([spice-server on non-x86/x86_64 architectures hasn't been extensively tested])
+ echo ""
+fi
+
echo \
" Now type 'make' to build $PACKAGE
"