summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2013-10-18 15:51:20 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2013-10-28 11:12:27 +0100
commitef9a8bf05328d290f82613037f5419f0d5e87eb5 (patch)
treed62db6bc2e7f60547fa7bdeb98af3f38ea00935a /configure.ac
parent1b6ced7ddafd1bc6e490af091427327b05c96b3f (diff)
downloadspice-ef9a8bf05328d290f82613037f5419f0d5e87eb5.tar.gz
spice-ef9a8bf05328d290f82613037f5419f0d5e87eb5.tar.xz
spice-ef9a8bf05328d290f82613037f5419f0d5e87eb5.zip
Remove tunneling support
It's depending on an unmaintained package (slirp), and I don't think anyone uses that code. It's not tested upstream nor in fedora, so let's remove it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 1 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index b781d341..7e81329c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,16 +118,7 @@ AM_CONDITIONAL(OS_UNIX, test "$os_win32" != "yes")
AM_CONDITIONAL(OS_LINUX, test "$os_linux" = "yes")
dnl =========================================================================
-dnl Chek optional features
-AC_ARG_ENABLE(tunnel,
-[ --enable-tunnel Enable network redirection],,
-[enable_tunnel="no"])
-AS_IF([test x"$enable_tunnel" != "xno"], [enable_tunnel="yes"])
-AM_CONDITIONAL(SUPPORT_TUNNEL, test "x$enable_tunnel" != "xno")
-if test "x$enable_tunnel" != "xno"; then
- AC_DEFINE([USE_TUNNEL], [1], [Define if supporting tunnel proxying])
-fi
-
+dnl Check optional features
AC_ARG_ENABLE(gui,
[ --enable-gui Enable start dialog with CEGUI],,
[enable_gui="no"])
@@ -221,14 +212,6 @@ if test "x$enable_gui" = "xyes" && test "x$enable_client" = "xyes" ; then
])
fi
-if test "x$enable_tunnel" = "xyes"; then
- PKG_CHECK_MODULES(SLIRP, slirp)
- AC_SUBST(SLIRP_CFLAGS)
- AC_SUBST(SLIRP_LIBS)
- SPICE_REQUIRES+=" slirp"
- AC_DEFINE([HAVE_SLIRP], [], [Define if we have slirp])
-fi
-
if test "x$enable_smartcard" = "xyes"; then
PKG_CHECK_MODULES(CAC_CARD, libcacard >= 0.1.2)
SMARTCARD_LIBS="$CAC_CARD_LIBS"
@@ -535,8 +518,6 @@ echo "
GUI: ${enable_gui}
" ; fi ; echo "\
- Support tunneling: ${enable_tunnel}
-
Smartcard: ${enable_smartcard}
SASL support: ${enable_sasl}