summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJavier Celaya <javier.celaya@flexvm.es>2014-11-13 17:00:58 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2014-12-02 19:41:17 +0100
commitb532ef0866cefe260ad0f08550f7c40d3580d0d7 (patch)
tree29a0c98c41d61178cc0ac66db359073caacd05b8 /configure.ac
parent84b3a5079d6014d50e3018b24949d5a2e18e3c78 (diff)
downloadspice-b532ef0866cefe260ad0f08550f7c40d3580d0d7.tar.gz
spice-b532ef0866cefe260ad0f08550f7c40d3580d0d7.tar.xz
spice-b532ef0866cefe260ad0f08550f7c40d3580d0d7.zip
Add LZ4 compression support.
- Add lz4 encoder to compress an image of type LZ4 (see spice_common). - Add code in red_worker to use LZ4 when it is enabled, and the client supports it through its display capability, or fallback to LZ. - Add enable_lz4 switch in the configure script. Show LZ4 support at the end.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c9d83e1a..7545ba05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -138,6 +138,12 @@ AC_ARG_ENABLE(opengl,
AS_IF([test x"$enable_opengl" != "xno"], [enable_opengl="yes"])
AM_CONDITIONAL(SUPPORT_GL, test "x$enable_opengl" = "xyes")
+AC_ARG_ENABLE(lz4,
+[ --enable-lz4 Enable lz4 compression algorithm],,
+[enable_lz4="no"])
+AS_IF([test x"$enable_lz4" != "xno"], [enable_lz4="yes"])
+AM_CONDITIONAL(SUPPORT_LZ4, test "x$enable_lz4" = "xyes")
+
AC_ARG_ENABLE(smartcard,
[ --enable-smartcard Enable network redirection],,
[enable_smartcard="no"])
@@ -287,6 +293,13 @@ AC_ARG_ENABLE([xinerama],
[AS_HELP_STRING([--disable-xinerama],
[disable Xinerama library @<:@default=no@:>@])])
+if test "x$enable_lz4" = "xyes"; then
+ PKG_CHECK_MODULES(LZ4, liblz4)
+ AC_DEFINE([USE_LZ4], [1], [Define to build with Lz4 support])
+fi
+AC_SUBST(LZ4_CFLAGS)
+AC_SUBST(LZ4_LIBS)
+
if test "x$red_target" = "xx11" && test "x$enable_client" = "xyes" ; then
if test "$os_linux" = yes; then
PKG_CHECK_MODULES(ALSA, alsa)
@@ -549,6 +562,8 @@ echo "
GUI: ${enable_gui}
" ; fi ; echo "\
+ LZ4 support: ${enable_lz4}
+
Smartcard: ${enable_smartcard}
SASL support: ${enable_sasl}