summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2011-04-19 18:49:56 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2011-05-02 11:24:43 +0200
commitae0a9fc1d30665271e527c7cec84a006474e4b0a (patch)
tree8e5ccdbeddfdac6435531c5b7dcf159dac182e5f /configure.ac
parent36292b07408b72c7b8afd4758e19cd1f9471cd2e (diff)
downloadspice-ae0a9fc1d30665271e527c7cec84a006474e4b0a.tar.gz
spice-ae0a9fc1d30665271e527c7cec84a006474e4b0a.tar.xz
spice-ae0a9fc1d30665271e527c7cec84a006474e4b0a.zip
configure.ac: remove unused dynamic linkage flag
configure.ac defines a SPICEC_STATIC_LINKAGE_BDYNAMIC variable when --enable-static-linkage is not set, but it's never used. SPICEC_STATIC_LINKAGE_BSTATIC is used in client/, but since we are using libtool, it might be more appropriate to use 'make LDFLAGS="-all-static"' to achieve static link.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 78a1f46e..eff0e074 100644
--- a/configure.ac
+++ b/configure.ac
@@ -272,8 +272,7 @@ AC_ARG_ENABLE(static-linkage,
[ --enable-static-linkage will generate spice client binary with static linkage to external libraries ],,
[enable_static_linkage="no"])
AS_IF([test x"$enable_static_linkage" != "xno"],
-[SPICEC_STATIC_LINKAGE_BSTATIC=["-Wl,-Bstatic"]],
-[SPICEC_STATIC_LINKAGE_BDYNAMIC=["-Wl,-Bdynamic"]])
+[SPICEC_STATIC_LINKAGE_BSTATIC=["-Wl,-Bstatic"]])
AS_IF([test "$_cflags_is_set" = "yes"], [], [
@@ -489,7 +488,6 @@ AC_SUBST(SPICE_NONPKGCONFIG_CFLAGS)
AC_SUBST(SPICE_NONPKGCONFIG_LIBS)
AC_SUBST([SPICEC_STATIC_LINKAGE_BSTATIC])
-AC_SUBST([SPICEC_STATIC_LINKAGE_BDYNAMIC])
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])