summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGerd Hoffmann <kraxel@redhat.com>2010-07-08 11:40:54 +0200
committerAlon Levy <alevy@redhat.com>2010-12-07 21:36:37 +0200
commit71aad4d7e8f639e48709bf8515dc4c96342b90e3 (patch)
treed72207a37efbbf2f32766cc0ec8e4be053cfe6e7 /configure.ac
parent09c0e2de2c2fb2450f056f0263a1143769d061d1 (diff)
downloadspice-71aad4d7e8f639e48709bf8515dc4c96342b90e3.tar.gz
spice-71aad4d7e8f639e48709bf8515dc4c96342b90e3.tar.xz
spice-71aad4d7e8f639e48709bf8515dc4c96342b90e3.zip
mingw32 build: add client/windows/Makefile, tweak configure
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4b732b59..5fdc5447 100644
--- a/configure.ac
+++ b/configure.ac
@@ -138,7 +138,11 @@ AC_CHECK_LIB(rt, clock_gettime,
)
AC_SUBST(LIBRT)
-SPICE_NONPKGCONFIG_LIBS+=" -pthread $LIBM $LIBRT"
+if test "$red_target" = "windows"; then
+ SPICE_NONPKGCONFIG_LIBS+=" -lpthreadGC2 -lversion -lmsimg32 $LIBM"
+else
+ SPICE_NONPKGCONFIG_LIBS+=" -pthread $LIBM $LIBRT"
+fi
dnl The client needs a yield function
AC_MSG_CHECKING(for posix yield function)
@@ -323,7 +327,11 @@ dnl MAYBE_WARN in an ignorable way (like adding whitespace)
dnl MAYBE_WARN="-Wall -Wno-sign-compare -Werror -Wno-deprecated-declarations"
-MAYBE_WARN="-Wall -Wno-sign-compare -Wno-deprecated-declarations"
+if test "$red_target" = "windows"; then
+ MAYBE_WARN="-Wall -Wno-sign-compare -Wno-deprecated-declarations"
+else
+ MAYBE_WARN="-Wall -Wno-sign-compare -Werror -Wno-deprecated-declarations"
+fi
AC_ARG_ENABLE(werror,
AC_HELP_STRING([--enable-werror], [Use -Werror (if supported)]),