summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2015-10-07 15:58:36 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2015-10-07 18:26:00 +0200
commit5d0649b8f00654e93cb7f8bc4756de567eb89771 (patch)
tree3e896cf65499e5acab5fbf5d7dd32fb6c265726e /configure.ac
parent9e75019e653f4f79d5287ba8288726ad88f97fee (diff)
downloadspice-5d0649b8f00654e93cb7f8bc4756de567eb89771.tar.gz
spice-5d0649b8f00654e93cb7f8bc4756de567eb89771.tar.xz
spice-5d0649b8f00654e93cb7f8bc4756de567eb89771.zip
build-sys: Remove client check from configure.ac
configure.ac is checking for pyparsing availability if client/generated_marshallers.cpp is missing. The client/ code is gone, and the python modules checks are done in spice-common/configure.ac nowadays, so we can get rid of this check.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 8ab4c4ad..283bdb86 100644
--- a/configure.ac
+++ b/configure.ac
@@ -130,16 +130,6 @@ if test "x$enable_celt051" = "xyes"; then
PKG_CHECK_MODULES(CELT051, celt051 >= 0.5.1.1, AS_VAR_APPEND([SPICE_REQUIRES], [" celt051 >= 0.5.1.1"]))
fi
-if test ! -e client/generated_marshallers.cpp; then
-AC_MSG_CHECKING([for pyparsing python module])
-echo "import pyparsing" | ${PYTHON} - >/dev/null 2>&1
-if test $? -ne 0 ; then
- AC_MSG_RESULT([not found])
- AC_MSG_ERROR([pyparsing python module is required to compile this package])
-fi
-AC_MSG_RESULT([found])
-fi
-
PKG_CHECK_MODULES(SSL, openssl)
AC_SUBST(SSL_CFLAGS)
AC_SUBST(SSL_LIBS)