summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2011-04-19 17:21:48 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2011-05-02 11:24:44 +0200
commit06c83ca99458f611d871936c9d1bf433703a8f05 (patch)
treea22fc0365b8c68b3547c31a19963362529f458c1 /configure.ac
parentafffe11e66f8848ad88952e509aca936dc272d75 (diff)
downloadspice-06c83ca99458f611d871936c9d1bf433703a8f05.tar.gz
spice-06c83ca99458f611d871936c9d1bf433703a8f05.tar.xz
spice-06c83ca99458f611d871936c9d1bf433703a8f05.zip
client: make building client optional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c5f35348..a972470a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,6 +123,12 @@ if test "x$enable_smartcard" = "xyes"; then
AC_DEFINE(USE_SMARTCARD, [1], [Define if supporting smartcard proxying])
fi
+AC_ARG_ENABLE(client,
+[ --enable-client Enable spice client],,
+[enable_client="yes"])
+AS_IF([test x"$enable_client" != "xno"], [enable_client="yes"])
+AM_CONDITIONAL(SUPPORT_CLIENT, test "x$enable_client" = "xyes")
+
dnl =========================================================================
dnl Check deps
@@ -517,6 +523,8 @@ echo "
c compiler: ${CC}
c++ compiler: ${CXX}
+ Build Spice client: ${enable_client}
+
Have XRANDR 1.2: ${have_xrandr12}
Support tunneling: ${enable_tunnel}