summaryrefslogtreecommitdiffstats
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2010-09-15 15:55:37 +0200
committerAlon Levy <alevy@redhat.com>2010-12-07 13:31:44 +0200
commit7e0a1dfa75d9c967b96929c56dce4cecb7151a85 (patch)
tree4ec0b7cd9442d8353878f10007bf3c3c629dbc9f /client/Makefile.am
parentd99ec6c35b02a64950c4397644a9a81fad1d4492 (diff)
downloadspice-7e0a1dfa75d9c967b96929c56dce4cecb7151a85.tar.gz
spice-7e0a1dfa75d9c967b96929c56dce4cecb7151a85.tar.xz
spice-7e0a1dfa75d9c967b96929c56dce4cecb7151a85.zip
smartcard: configure option --enable-smartcard
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 5a14f5fd..166ce5e9 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -28,6 +28,12 @@ else
GL_SRCS =
endif
+if SUPPORT_SMARTCARD
+SMARTCARD_SRCS = smartcard_channel.cpp
+else
+SMARTCARD_SRCS =
+endif
+
RED_COMMON_SRCS = \
application.cpp \
application.h \
@@ -134,6 +140,6 @@ GDI_FILES = \
MAINTAINERCLEANFILES = $(spice_built_sources)
-EXTRA_DIST = $(RED_COMMON_SRCS) $(spice_built_sources) $(GL_SRCS) $(GDI_FILES)
+EXTRA_DIST = $(RED_COMMON_SRCS) $(spice_built_sources) $(GL_SRCS) $(GDI_FILES) $(SMARTCARD_SRCS)
BUILT_SOURCES = $(spice_built_sources)