summaryrefslogtreecommitdiffstats
path: root/python_modules/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'python_modules/Makefile.am')
-rw-r--r--python_modules/Makefile.am17
1 files changed, 8 insertions, 9 deletions
diff --git a/python_modules/Makefile.am b/python_modules/Makefile.am
index 50e1a71..3a4515a 100644
--- a/python_modules/Makefile.am
+++ b/python_modules/Makefile.am
@@ -1,16 +1,15 @@
NULL =
-PYTHON_MODULES = \
- __init__.py \
- codegen.py \
- demarshal.py \
- marshal.py \
- ptypes.py \
- spice_parser.py \
+python_codegendir = $(libdir)/spice-protocol/python_modules
+dist_python_codegen_DATA = \
+ __init__.py \
+ codegen.py \
+ demarshal.py \
+ marshal.py \
+ ptypes.py \
+ spice_parser.py \
$(NULL)
-EXTRA_DIST = $(PYTHON_MODULES)
-
DISTCLEANFILES = *.pyc
-include $(top_srcdir)/git.mk