summaryrefslogtreecommitdiffstats
path: root/python_modules/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2015-08-07 11:52:25 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2015-08-07 11:52:25 +0200
commit26eb4e0f2edf6e6183ef8bd9a35564d72260e5e0 (patch)
tree6e03283c695c1e07a7b0c02101d309f3c2666a41 /python_modules/Makefile.am
parent666b5c5780acf3176a9cff61ad549d30bb1b9824 (diff)
parent1d026b9a71a12df119f5582c9a42be08259b0bac (diff)
downloadspice-protocol-26eb4e0f2edf6e6183ef8bd9a35564d72260e5e0.tar.gz
spice-protocol-26eb4e0f2edf6e6183ef8bd9a35564d72260e5e0.tar.xz
spice-protocol-26eb4e0f2edf6e6183ef8bd9a35564d72260e5e0.zip
Merge protocol code generation bits from spice-common
The history for spice*.proto, spice_codegen.py and python_modules/ was extracted from spice-common using git filter-branch: git filter-branch \ --prune-empty \ --index-filter ' git ls-tree -z -r --name-only --full-tree $GIT_COMMIT \ | grep -z -v "^python_modules/" \ | grep -z -v "^spice.proto" \ | grep -z -v "^spice1.proto" \ | grep -z -v "^spice_codegen.py" \ | xargs -0 -r git rm -f --cached -r ' \ -- \ --all git filter-branch --force \ --prune-empty \ --index-filter ' git rm -f spice-protocol --cached --ignore-unmatch ' \ -- \ --all
Diffstat (limited to 'python_modules/Makefile.am')
-rw-r--r--python_modules/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/python_modules/Makefile.am b/python_modules/Makefile.am
new file mode 100644
index 0000000..50e1a71
--- /dev/null
+++ b/python_modules/Makefile.am
@@ -0,0 +1,16 @@
+NULL =
+
+PYTHON_MODULES = \
+ __init__.py \
+ codegen.py \
+ demarshal.py \
+ marshal.py \
+ ptypes.py \
+ spice_parser.py \
+ $(NULL)
+
+EXTRA_DIST = $(PYTHON_MODULES)
+
+DISTCLEANFILES = *.pyc
+
+-include $(top_srcdir)/git.mk