summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2015-08-10 18:00:45 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2015-08-10 18:00:45 +0200
commit03a28f58569524300f22a8401f4f6ca6b0037e54 (patch)
tree574ab30045bac73686367bd1a79ce8c37f452105 /Makefile.am
parent52ae5ed2c8b16d3f1bd09709209f822cfce5ed9a (diff)
downloadspice-protocol-03a28f58569524300f22a8401f4f6ca6b0037e54.tar.gz
spice-protocol-03a28f58569524300f22a8401f4f6ca6b0037e54.tar.xz
spice-protocol-03a28f58569524300f22a8401f4f6ca6b0037e54.zip
build-sys: Make installed spice_codegen.py is executable
Files listed as _DATA in Makefile.am are installed without the executable bit set, files listed as _SCRIPT do get the executable bit set. As spice_codegen.py is meant to be run by spice-protocol users, make sure this bit is set.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1082bf2..53e87be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,11 +4,14 @@ SUBDIRS = python_modules spice
codegendir = $(libdir)/spice-protocol
dist_codegen_DATA = \
- spice_codegen.py \
spice.proto \
spice1.proto \
$(NULL)
+dist_codegen_SCRIPTS = \
+ spice_codegen.py \
+ $(NULL)
+
DISTCLEANFILES = *.pyc
pkgconfigdir = $(datadir)/pkgconfig