summaryrefslogtreecommitdiffstats
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2014-04-22 10:40:36 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2014-08-13 17:21:34 +0200
commit49816b49005e82565c20a66ad89c72cba2692962 (patch)
tree19fc62c03e25b11ae7919561c4eb2334fd83040a /gtk/Makefile.am
parent8a67393628fcadd66e9ef95fd182eb81698bc0c7 (diff)
downloadspice-gtk-49816b49005e82565c20a66ad89c72cba2692962.tar.gz
spice-gtk-49816b49005e82565c20a66ad89c72cba2692962.tar.xz
spice-gtk-49816b49005e82565c20a66ad89c72cba2692962.zip
Fix build with automake 1.14
When building a source file from a different directory, automake 1.14 is warning that the automake option 'subdir-objects' must be used: automake: warnings are treated as errors gtk/Makefile.am:218: warning: source file '$(top_srcdir)/spice-common/common/sw_canvas.c' is in a subdirectory, gtk/Makefile.am:218: but option 'subdir-objects' is disabled automake: warning: possible forward-incompatibility. automake: At least a source file is in a subdirectory, but the 'subdir-objects' automake: automake option hasn't been enabled. For now, the corresponding output automake: object file(s) will be placed in the top-level directory. However, automake: this behaviour will change in future Automake versions: they will automake: unconditionally cause object files to be placed in the same subdirectory automake: of the corresponding sources. automake: You are advised to start using 'subdir-objects' option throughout your automake: project, to avoid future incompatibilities. autoreconf: automake failed with exit status: 1 This causes the build to fail because we are also using the -Werror automake option. Updating the spice-common submodule to git master fixes part of this issue as 7ea1cc5 'Fix generation of marshallers in VPATH builds' removed directory references from some source files. This commit removes the references to $(top_srcdir)/spice-common/common/sw_canvas.[ch] from gtk/Makefile.am. At this point, automake subdir-objects support does not seem to cope very well with source files which are not in relative subdirectories, see http://mytestbed.net/issues/1327 What is done instead is to add some local client_sw_canvas.[ch] files which will include the needed files from spice-common with the appropriate #define set (these sw_canvas.[ch] files are meant to be used as templates). This fixes https://bugs.freedesktop.org/show_bug.cgi?id=67304
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index f70f821..3d87958 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -72,7 +72,6 @@ KEYMAP_GEN = $(srcdir)/keymap-gen.pl
SPICE_COMMON_CPPFLAGS = \
-DG_LOG_DOMAIN=\"GSpice\" \
-DSPICE_NO_DEPRECATED \
- -DSW_CANVAS_CACHE \
-DSPICE_GTK_LOCALEDIR=\"${SPICE_GTK_LOCALEDIR}\" \
-DPNP_IDS=\""$(PNP_IDS)"\" \
-DUSB_IDS=\""$(USB_IDS)"\" \
@@ -271,8 +270,8 @@ libspice_client_glib_2_0_la_SOURCES = \
decode-jpeg.c \
decode-zlib.c \
\
- $(top_srcdir)/spice-common/common/sw_canvas.c \
- $(top_srcdir)/spice-common/common/sw_canvas.h \
+ client_sw_canvas.c \
+ client_sw_canvas.h \
$(NULL)
if WITH_GPROXY