summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2015-06-17 19:26:56 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2015-06-22 19:46:39 +0200
commite379c340b724aa4a53be0915b9d7818bfc6fe751 (patch)
tree5180199d407f94721fdc2071f18465b8a9860755 /configure.ac
parente1dfac38bdae1adeb601f9c5582ad0afef566aa2 (diff)
downloadspice-gtk-e379c340b724aa4a53be0915b9d7818bfc6fe751.tar.gz
spice-gtk-e379c340b724aa4a53be0915b9d7818bfc6fe751.tar.xz
spice-gtk-e379c340b724aa4a53be0915b9d7818bfc6fe751.zip
build-sys: Use SPICE_CHECK_LZ4
spice-common now has an m4 macro adding a --enable-lz4 option and doing the needed checks, so we can use it in configure.ac rather than duplicating it here.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 1 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 5732c95..d1234c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -677,18 +677,7 @@ if test "x$enable_dbus" != "xno"; then
fi
fi
-AC_ARG_ENABLE([lz4],
- AS_HELP_STRING([--enable-lz4=@<:@yes/no@:>@],
- [Enable lz4 compression algorithm @<:@default=no@:>@]),
- [],
- [enable_lz4="no"])
-
-if test "x$enable_lz4" = "xyes"; then
- PKG_CHECK_MODULES(LZ4, liblz4)
- AC_DEFINE([USE_LZ4], [1], [Define to build with Lz4 support])
-fi
-AC_SUBST(LZ4_CFLAGS)
-AC_SUBST(LZ4_LIBS)
+SPICE_CHECK_LZ4([LZ4])
dnl ===========================================================================
dnl check compiler flags