summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2014-02-24 15:00:31 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2014-02-24 15:59:41 +0100
commite124a3b2e8d375661aeed9c151866c46985d7afa (patch)
tree1f51c2883e642fed299692cdacad9b97e98f25de /configure.ac
parent603bad139cd4ee0eb6096037956f3af6fec33730 (diff)
downloadspice-gtk-e124a3b2e8d375661aeed9c151866c46985d7afa.tar.gz
spice-gtk-e124a3b2e8d375661aeed9c151866c46985d7afa.tar.xz
spice-gtk-e124a3b2e8d375661aeed9c151866c46985d7afa.zip
Add a SPICE_GTK_CHECK_VERSION macro
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6e4b29a..192d748 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,6 +75,15 @@ AC_CONFIG_SUBDIRS([spice-common])
COMMON_CFLAGS='-I ${top_srcdir}/spice-common/ -I ${top_srcdir}/spice-common/spice-protocol/'
AC_SUBST(COMMON_CFLAGS)
+SPICE_GTK_MAJOR_VERSION=`echo $PACKAGE_VERSION | cut -d. -f1`
+SPICE_GTK_MINOR_VERSION=`echo $PACKAGE_VERSION | cut -d. -f2`
+SPICE_GTK_MICRO_VERSION=`echo $PACKAGE_VERSION | cut -d. -f3 | cut -d- -f1`
+[ "x$SPICE_GTK_MICRO_VERSION" = "x" ] && SPICE_GTK_MICRO_VERSION = 0
+
+AC_SUBST(SPICE_GTK_MAJOR_VERSION)
+AC_SUBST(SPICE_GTK_MINOR_VERSION)
+AC_SUBST(SPICE_GTK_MICRO_VERSION)
+
dnl =========================================================================
dnl Chek optional features
@@ -709,6 +718,7 @@ data/spicy.desktop.in
data/spicy.nsis
po/Makefile.in
gtk/Makefile
+gtk/spice-version.h
gtk/controller/Makefile
doc/Makefile
doc/reference/Makefile