summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2014-04-02 13:49:36 +0200
committerMarc-André Lureau <marcandre.lureau@redhat.com>2014-04-02 13:52:30 +0200
commitd17d43ce5c43a83cbd7309f8d4fda3b802fa556a (patch)
treeffbb8b3dbb5aec5596ad7078e0ac1865f622d937 /configure.ac
parentd4814544eae305f974de2b0303d11ec67f54294c (diff)
downloadspice-gtk-d17d43ce5c43a83cbd7309f8d4fda3b802fa556a.tar.gz
spice-gtk-d17d43ce5c43a83cbd7309f8d4fda3b802fa556a.tar.xz
spice-gtk-d17d43ce5c43a83cbd7309f8d4fda3b802fa556a.zip
Make phodav an optional external dependency
Now that upstream provides a stable/versioned API, it will be easier to deal with than with submodules.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fa3a2e4..45417d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,8 +75,6 @@ AC_CONFIG_SUBDIRS([spice-common])
COMMON_CFLAGS='-I ${top_srcdir}/spice-common/ -I ${top_srcdir}/spice-common/spice-protocol/'
AC_SUBST(COMMON_CFLAGS)
-AC_CONFIG_SUBDIRS([gtk/phodav])
-
SPICE_GTK_MAJOR_VERSION=`echo $PACKAGE_VERSION | cut -d. -f1`
SPICE_GTK_MINOR_VERSION=`echo $PACKAGE_VERSION | cut -d. -f2`
SPICE_GTK_MICRO_VERSION=`echo $PACKAGE_VERSION | cut -d. -f3 | cut -d- -f1`
@@ -273,6 +271,11 @@ PKG_CHECK_MODULES(SOUP, libsoup-2.4)
AC_SUBST(SOUP_CFLAGS)
AC_SUBST(SOUP_LIBS)
+PKG_CHECK_MODULES(PHODAV, [libphodav-1.0], [have_phodav=yes], [have_phodav=no])
+AC_SUBST(PHODAV_CFLAGS)
+AC_SUBST(PHODAV_LIBS)
+AS_IF([test "x$have_phodav" = "xyes"],
+ AC_DEFINE(USE_PHODAV, [1], [Define if supporting phodav]))
AC_ARG_WITH([audio],
AS_HELP_STRING([--with-audio=@<:@gstreamer/pulse/auto/no@:>@], [Select audio backend @<:@default=auto@:>@]),
@@ -750,6 +753,7 @@ AC_MSG_NOTICE([
Smartcard support: ${have_smartcard}
USB redirection support: ${have_usbredir} ${with_usbredir_hotplug}
DBus: ${have_dbus}
+ PhoDAV: ${have_phodav}
Now type 'make' to build $PACKAGE