summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTiziano Müller <tiziano.mueller@stepping-stone.ch>2014-05-21 08:07:43 +0200
committerMarc-André Lureau <marcandre.lureau@redhat.com>2014-05-21 11:28:12 +0200
commitb637cd43daf1a6e1c8cbdd3e3a88e5626f88901c (patch)
tree241eec05ab34b658b6f91f249c338c4c9f8ae77c /configure.ac
parentaea53ec51d1a51c70b6cf07e3a5a4fddd613406f (diff)
downloadspice-gtk-b637cd43daf1a6e1c8cbdd3e3a88e5626f88901c.tar.gz
spice-gtk-b637cd43daf1a6e1c8cbdd3e3a88e5626f88901c.tar.xz
spice-gtk-b637cd43daf1a6e1c8cbdd3e3a88e5626f88901c.zip
Introduce --enable/disable-webdav option
This makes the phodav dependency configureable. And name it after the corresponding channel.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 17 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index d89bd6f..70ab75c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -270,10 +270,23 @@ AC_SUBST(GTHREAD_LIBS)
PKG_CHECK_MODULES(SOUP, libsoup-2.4)
AC_SUBST(SOUP_CFLAGS)
AC_SUBST(SOUP_LIBS)
+AC_ARG_ENABLE([webdav],
+ AS_HELP_STRING([--enable-webdav=@<:@auto/yes/no@:>@],
+ [Enable webdav support @<:@default=auto@:>@]),
+ [],
+ [enable_webdav="auto"])
+
+if test "x$enable_webdav" = "xno"; then
+ have_phodav="no"
+else
+ PKG_CHECK_MODULES(PHODAV, [libphodav-1.0], [have_phodav=yes], [have_phodav=no])
+ AC_SUBST(PHODAV_CFLAGS)
+ AC_SUBST(PHODAV_LIBS)
-PKG_CHECK_MODULES(PHODAV, [libphodav-1.0], [have_phodav=yes], [have_phodav=no])
-AC_SUBST(PHODAV_CFLAGS)
-AC_SUBST(PHODAV_LIBS)
+ if test "x$have_phodav" = "xno" && test "x$enable_webdav" = "xyes"; then
+ AC_MSG_ERROR([webdav support explicitly requested, but some required packages are not available])
+ fi
+fi
AS_IF([test "x$have_phodav" = "xyes"],
AC_DEFINE(USE_PHODAV, [1], [Define if supporting phodav]))
@@ -754,7 +767,7 @@ AC_MSG_NOTICE([
Smartcard support: ${have_smartcard}
USB redirection support: ${have_usbredir} ${with_usbredir_hotplug}
DBus: ${have_dbus}
- PhoDAV: ${have_phodav}
+ WebDAV support: ${have_phodav}
Now type 'make' to build $PACKAGE