summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2015-11-09 20:22:07 +0100
committerMarc-André Lureau <marcandre.lureau@gmail.com>2016-02-13 11:28:24 +0100
commit983eed10736870cd435c92e3443c58d364c72b6d (patch)
tree7ada0793b63b3e1691193dbef546100e33fbba95 /configure.ac
parent1877229a43c411f4145a767730c617c5714bc979 (diff)
downloadspice-gtk-983eed10736870cd435c92e3443c58d364c72b6d.tar.gz
spice-gtk-983eed10736870cd435c92e3443c58d364c72b6d.tar.xz
spice-gtk-983eed10736870cd435c92e3443c58d364c72b6d.zip
build-sys: check for epoxy-egl support
The following code requires epoxy with egl support. Check for pkg-config and egl headers. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0beec7c..4168290 100644
--- a/configure.ac
+++ b/configure.ac
@@ -243,6 +243,31 @@ AS_IF([test "x$have_phodav" = "xyes"],
AM_CONDITIONAL([WITH_PHODAV], [test "x$have_phodav" = "xyes"])
+# FIXME: remove with gtk2
+AC_ARG_ENABLE([epoxy],
+ AS_HELP_STRING([--enable-epoxy=@<:@auto/yes/no@:>@],
+ [Enable egl/epoxy support @<:@default=auto@:>@]),
+ [],
+ [enable_epoxy="auto"])
+
+if test "x$enable_epoxy" = "xno"; then
+ have_epoxy="no"
+else
+ PKG_CHECK_MODULES(EPOXY, [epoxy], [have_epoxy=yes], [have_epoxy=no])
+ AC_SUBST(EPOXY_CFLAGS)
+ AC_SUBST(EPOXY_LIBS)
+ if test "x$have_epoxy" = "xyes"; then
+ AC_CHECK_HEADER([epoxy/egl.h],,have_epoxy=no)
+ fi
+ if test "x$have_epoxy" = "xno" && test "x$enable_epoxy" = "xyes"; then
+ AC_MSG_ERROR([epoxy support explicitly requested, but required package is not available])
+ fi
+fi
+AS_IF([test "x$have_epoxy" = "xyes"],
+ AC_DEFINE(USE_EPOXY, [1], [Define if supporting epoxy]))
+
+AM_CONDITIONAL([WITH_EPOXY], [test "x$have_epoxy" = "xyes"])
+
AC_ARG_WITH([audio],
AS_HELP_STRING([--with-audio=@<:@gstreamer/pulse/auto/no@:>@], [For legacy compatibility only]),
[SPICE_WARNING([--with-audio is deprecated. Use --enable-pulse and/or --enable-gstaudio instead])
@@ -705,6 +730,7 @@ AC_MSG_NOTICE([
DBus: ${have_dbus}
WebDAV support: ${have_phodav}
LZ4 support: ${enable_lz4}
+ epoxy: ${have_epoxy}
Now type 'make' to build $PACKAGE