summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2014-10-29 16:59:33 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2014-10-30 17:47:15 +0100
commit94142f51b871362988e936a27844344cc9635143 (patch)
treeebcfbf54645d22c31f8ee658742c999ddb2d4da4 /configure.ac
parent65545d23cd55e3f49a9c2b481a5c3fd77e3015a8 (diff)
downloadspice-gtk-94142f51b871362988e936a27844344cc9635143.tar.gz
spice-gtk-94142f51b871362988e936a27844344cc9635143.tar.xz
spice-gtk-94142f51b871362988e936a27844344cc9635143.zip
build-sys: Don't use test -a/-o
They are not portable, it's recommended to use test && test or test || test instead
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 0d65823..35a2140 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,7 +121,7 @@ SASL_CFLAGS=
SASL_LIBS=
enable_sasl=no
if test "x$with_sasl" != "xno"; then
- if test "x$with_sasl" != "xyes" -a "x$with_sasl" != "xauto"; then
+ if test "x$with_sasl" != "xyes" && test "x$with_sasl" != "xauto"; then
SASL_CFLAGS="-I$with_sasl"
SASL_LIBS="-L$with_sasl"
fi
@@ -133,7 +133,7 @@ if test "x$with_sasl" != "xno"; then
if test "x$with_sasl" = "xyes" ; then
AC_CHECK_LIB([sasl2], [sasl_client_init],[with_sasl2=yes],[with_sasl2=no])
fi
- if test "x$with_sasl2" = "xno" -a "x$with_sasl" = "xyes" ; then
+ if test "x$with_sasl2" = "xno" && test "x$with_sasl" = "xyes" ; then
AC_CHECK_LIB([sasl], [sasl_client_init],[with_sasl=yes],[with_sasl=no])
fi
if test "x$with_sasl2" = "xyes"; then
@@ -145,13 +145,13 @@ if test "x$with_sasl" != "xno"; then
fi
CFLAGS="$old_cflags"
LIBS="$old_libs"
- if test "x$with_sasl2" = "xyes" -o "x$with_sasl" = "xyes" ; then
+ if test "x$with_sasl2" = "xyes" || test "x$with_sasl" = "xyes" ; then
AC_DEFINE_UNQUOTED([HAVE_SASL], 1,
[whether Cyrus SASL is available for authentication])
enable_sasl=yes
fi
fi
-AM_CONDITIONAL([HAVE_SASL], [test "x$with_sasl2" = "xyes" -o "x$with_sasl" = "xyes"])
+AM_CONDITIONAL([HAVE_SASL], [test "x$with_sasl2" = "xyes" || test "x$with_sasl" = "xyes"])
AC_SUBST([SASL_CFLAGS])
AC_SUBST([SASL_LIBS])