summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2011-03-30 17:29:56 +0200
committerMarc-André Lureau <marcandre.lureau@redhat.com>2011-03-30 17:29:56 +0200
commit9237548d9a81cda3074769368a09bd7732fc96aa (patch)
treeb21027f174dbaa9f263aa879a619775add090301 /configure.ac
parent3f54948390f4258b27b106cf7f58b71f02a08978 (diff)
downloadspice-gtk-9237548d9a81cda3074769368a09bd7732fc96aa.tar.gz
spice-gtk-9237548d9a81cda3074769368a09bd7732fc96aa.tar.xz
spice-gtk-9237548d9a81cda3074769368a09bd7732fc96aa.zip
build: provide a conditional for WIN32
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 498d1e6..1b4754a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,18 @@ AC_C_BIGENDIAN
AC_PATH_PROGS(PYTHON, python2 python)
RRA_LD_VERSION_SCRIPT
+AC_MSG_CHECKING([for native Win32])
+case "$host_os" in
+ *mingw*|*cygwin*)
+ os_win32=yes
+ ;;
+ *)
+ os_win32=no
+ ;;
+esac
+AC_MSG_RESULT([$os_win32])
+AM_CONDITIONAL([OS_WIN32],[test "$os_win32" = "yes"])
+
AC_CHECK_HEADERS([sys/ipc.h sys/shm.h])
AC_CHECK_HEADERS([sys/socket.h netinet/in.h arpa/inet.h])