summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFrancois Gouget <fgouget@codeweavers.com>2015-11-23 17:33:56 +0100
committerVictor Toso <victortoso@redhat.com>2015-11-24 09:28:42 +0100
commit449ccb3f2564c1fb98fcdd0f7776ad2f738740ba (patch)
tree9e41846e7f9752c710d5604d8ecbc9272adac9a7 /configure.ac
parentdf331737d1c9ab5e680dfb3fd91897f3179cf4b6 (diff)
downloadspice-gtk-449ccb3f2564c1fb98fcdd0f7776ad2f738740ba.tar.gz
spice-gtk-449ccb3f2564c1fb98fcdd0f7776ad2f738740ba.tar.xz
spice-gtk-449ccb3f2564c1fb98fcdd0f7776ad2f738740ba.zip
build-sys: Prefix the configure audio GStreamer variables with GSTAUDIO_
This lets us avoid naming conflicts when using GStreamer for other purposes. Signed-off-by: Francois Gouget <fgouget@codeweavers.com> Acked-by: Victor Toso <victortoso@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 7033cbb..98de1c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -298,7 +298,7 @@ AC_ARG_WITH([audio],
case "$with_audio" in
gstreamer|pulse|auto*)
- PKG_CHECK_MODULES(GST, gstreamer-1.0 gstreamer-base-1.0 gstreamer-app-1.0 gstreamer-audio-1.0, [have_gst=yes], [have_gst=no])
+ PKG_CHECK_MODULES(GSTAUDIO, gstreamer-1.0 gstreamer-base-1.0 gstreamer-app-1.0 gstreamer-audio-1.0, [have_gstaudio=yes], [have_gstaudio=no])
PKG_CHECK_MODULES(PULSE, libpulse libpulse-mainloop-glib, [have_pulse=yes], [have_pulse=no])
;;
no*)
@@ -309,7 +309,7 @@ esac
AS_IF([test "x$with_audio" = "xauto" && test "x$have_pulse" = "xyes"],
[with_audio=pulse])
-AS_IF([test "x$with_audio" = "xauto" && test "x$have_gst" = "xyes"],
+AS_IF([test "x$with_audio" = "xauto" && test "x$have_gstaudio" = "xyes"],
[with_audio=gstreamer])
AS_IF([test "x$with_audio" = "xauto"],
@@ -326,14 +326,14 @@ AC_SUBST(PULSE_CFLAGS)
AC_SUBST(PULSE_LIBS)
AS_IF([test "x$with_audio" = "xgstreamer"],
- [AS_IF([test "x$have_gst" = "xyes"],
- [AC_DEFINE([WITH_GSTAUDIO], 1, [Have GStreamer 1.0?])],
- [AC_MSG_ERROR([GStreamer 1.0 requested but not found])
+ [AS_IF([test "x$have_gstaudio" = "xyes"],
+ [AC_DEFINE([WITH_GSTAUDIO], 1, [Have GStreamer 1.0 audio?])],
+ [AC_MSG_ERROR([GStreamer 1.0 audio requested but not found])
])
])
-AM_CONDITIONAL([WITH_GSTAUDIO], [test "x$have_gst" = "xyes"])
-AC_SUBST(GST_CFLAGS)
-AC_SUBST(GST_LIBS)
+AM_CONDITIONAL([WITH_GSTAUDIO], [test "x$have_gstaudio" = "xyes"])
+AC_SUBST(GSTAUDIO_CFLAGS)
+AC_SUBST(GSTAUDIO_LIBS)
AC_CHECK_LIB(jpeg, jpeg_destroy_decompress,
AC_MSG_CHECKING([for jpeglib.h])
@@ -695,7 +695,7 @@ SPICE_CFLAGS="$SPICE_CFLAGS $WARN_CFLAGS"
AC_SUBST(SPICE_CFLAGS)
-SPICE_GLIB_CFLAGS="$PIXMAN_CFLAGS $PULSE_CFLAGS $GST_CFLAGS $GLIB2_CFLAGS $GIO_CFLAGS $GOBJECT2_CFLAGS $SSL_CFLAGS $SASL_CFLAGS"
+SPICE_GLIB_CFLAGS="$PIXMAN_CFLAGS $PULSE_CFLAGS $GSTAUDIO_CFLAGS $GLIB2_CFLAGS $GIO_CFLAGS $GOBJECT2_CFLAGS $SSL_CFLAGS $SASL_CFLAGS"
SPICE_GTK_CFLAGS="$SPICE_GLIB_CFLAGS $GTK_CFLAGS "
AC_SUBST(SPICE_GLIB_CFLAGS)