summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJavier Celaya <javier.celaya@flexvm.es>2014-11-13 16:58:03 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2014-12-02 19:46:07 +0100
commit37cc8a1750cdaa3abadc6d1489404a7b27a0c9c0 (patch)
tree8cd19463c4200000309d03f46212f9c96e8bf253 /configure.ac
parent14dc8e170e71e4b860afe84cd20900b462e9b132 (diff)
downloadspice-gtk-37cc8a1750cdaa3abadc6d1489404a7b27a0c9c0.tar.gz
spice-gtk-37cc8a1750cdaa3abadc6d1489404a7b27a0c9c0.tar.xz
spice-gtk-37cc8a1750cdaa3abadc6d1489404a7b27a0c9c0.zip
Add LZ4 compression algorithm support.
- Use PKG_CHECK_MODULES to find liblz4. - Set LZ4 display channel capability.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 613a128..b55f3a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -695,6 +695,19 @@ if test "x$enable_dbus" != "xno"; then
fi
fi
+AC_ARG_ENABLE([lz4],
+ AS_HELP_STRING([--enable-lz4=@<:@yes/no@:>@],
+ [Enable lz4 compression algorithm @<:@default=no@:>@]),
+ [],
+ [enable_lz4="no"])
+
+if test "x$enable_lz4" = "xyes"; then
+ PKG_CHECK_MODULES(LZ4, liblz4)
+ AC_DEFINE([USE_LZ4], [1], [Define to build with Lz4 support])
+fi
+AC_SUBST(LZ4_CFLAGS)
+AC_SUBST(LZ4_LIBS)
+
dnl ===========================================================================
dnl check compiler flags
@@ -765,6 +778,7 @@ AC_MSG_NOTICE([
USB redirection support: ${have_usbredir} ${with_usbredir_hotplug}
DBus: ${have_dbus}
WebDAV support: ${have_phodav}
+ LZ4 support: ${enable_lz4}
Now type 'make' to build $PACKAGE