summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2015-12-03 12:07:13 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2015-12-08 15:41:26 +0100
commit077024454c7d3b6c8e6a35446ca51f2db4a3ab71 (patch)
tree62ce514b542ff501fabd930ed6892eae2525be68 /configure.ac
parent538625415afc23bb48778f6b21ed2c5fe8a3da6f (diff)
downloadspice-gtk-077024454c7d3b6c8e6a35446ca51f2db4a3ab71.tar.gz
spice-gtk-077024454c7d3b6c8e6a35446ca51f2db4a3ab71.tar.xz
spice-gtk-077024454c7d3b6c8e6a35446ca51f2db4a3ab71.zip
build-sys: Check for GStreamer 1.0 audio with SPICE_CHECK_GSTREAMER()
Signed-off-by: Francois Gouget <fgouget@codeweavers.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 8 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 2943bab..d716467 100644
--- a/configure.ac
+++ b/configure.ac
@@ -323,19 +323,16 @@ AC_ARG_ENABLE([gstaudio],
[],
[enable_gstaudio="auto"])
AS_IF([test "x$enable_gstaudio" != "xno"],
- [PKG_CHECK_MODULES(GSTAUDIO, [gstreamer-1.0 gstreamer-base-1.0 gstreamer-app-1.0 gstreamer-audio-1.0],
- [AC_DEFINE([HAVE_GSTAUDIO], 1, [Have GStreamer 1.0 audio support?])
- enable_gstaudio="yes"],
+ [SPICE_CHECK_GSTREAMER(GSTAUDIO, 1.0, [gstreamer-1.0 gstreamer-base-1.0 gstreamer-app-1.0 gstreamer-audio-1.0],
+ [],
[AS_IF([test "x$enable_gstaudio" = "xyes"],
AC_MSG_ERROR([GStreamer 1.0 audio requested but not found]))
- enable_gstaudio="no"
- ])
-])
-AM_CONDITIONAL([HAVE_GSTAUDIO], [test "x$enable_gstaudio" = "xyes"])
-AC_SUBST(GSTAUDIO_CFLAGS)
-AC_SUBST(GSTAUDIO_LIBS)
+ ])
+ ], [have_gstaudio="no"]
+)
+AM_CONDITIONAL([HAVE_GSTAUDIO], [test "x$have_gstaudio" = "xyes"])
-AS_IF([test "x$enable_pulse$enable_gstaudio" = "xnono"],
+AS_IF([test "x$enable_pulse$have_gstaudio" = "xnono"],
[SPICE_WARNING([No PulseAudio or GStreamer 1.0 audio decoder, audio will not be streamed])
])
@@ -745,7 +742,7 @@ AC_MSG_NOTICE([
Gtk: ${with_gtk}
Coroutine: ${with_coroutine}
PulseAudio: ${enable_pulse}
- GStreamer Audio: ${enable_gstaudio}
+ GStreamer Audio: ${have_gstaudio}
SASL support: ${enable_sasl}
Smartcard support: ${have_smartcard}
USB redirection support: ${have_usbredir} ${with_usbredir_hotplug}