summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2011-12-22 12:53:44 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2011-12-22 15:14:06 +0100
commitc5f42f8fb31c371548107ddf4114115d0e269946 (patch)
treebb4bbbc286d9da45ce6d5095dc210e1a9d50fc35 /Makefile.am
parent004322519fccb24024977068fa7d24d58b4d1590 (diff)
downloadspice-gtk-c5f42f8fb31c371548107ddf4114115d0e269946.tar.gz
spice-gtk-c5f42f8fb31c371548107ddf4114115d0e269946.tar.xz
spice-gtk-c5f42f8fb31c371548107ddf4114115d0e269946.zip
Disable vala bindings unless --enable-vala is used
Currently, building vala bindings from a tarball is broken because spice-client-glib-2.0.deps is missing from the tarball. This commit adds it to EXTRA_DIST and also makes sure the vala bindings don't get built/installed unless --enable-vala has been passed to configure. This means vala must be installed to build the vala bindings from a tarball. Fixes fdo bug #44000.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9825349..48b7b46 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,12 @@
ACLOCAL_AMFLAGS = -I m4
NULL =
-SUBDIRS = common gtk po python_modules doc data vapi
+SUBDIRS = common gtk po python_modules doc data
+if HAVE_INTROSPECTION
+if WITH_VALA
+SUBDIRS += vapi
+endif
+endif
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = \
@@ -58,7 +63,14 @@ BUILT_SOURCES = $(top_srcdir)/.version
$(top_srcdir)/.version:
echo $(VERSION) > $@-t && mv $@-t $@
-DISTCHECK_CONFIGURE_FLAGS = --enable-introspection --enable-werror --enable-gtk-doc
+DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-introspection \
+ --disable-vala \
+ --disable-usbredir \
+ --enable-gtk-doc \
+ --enable-werror \
+ --with-gtk=3.0 \
+ $(NULL)
spicy-for-windows.exe:
PATH=$$PATH:/usr/i686-pc-mingw32/sys-root/mingw/bin/:/usr/i686-pc-mingw32/sys-root/mingw/lib \