summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2011-12-21 11:48:48 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2011-12-22 09:58:39 +0100
commit66ff918f37fb71f9b464a77b5c6835b8253fd43b (patch)
treea55eb4868f9aa0a3256273fa30c9fd9277335c83 /Makefile.am
parentd103002c17ab362f14f3487c3299115f7b0be720 (diff)
downloadspice-gtk-66ff918f37fb71f9b464a77b5c6835b8253fd43b.tar.gz
spice-gtk-66ff918f37fb71f9b464a77b5c6835b8253fd43b.tar.xz
spice-gtk-66ff918f37fb71f9b464a77b5c6835b8253fd43b.zip
build: ship vala files & fix make distcheck
Disable usbredir, since it wants to install file in /. Disable vala for distcheck for 2 reasons: not needed after dist and binding build issue. Ship with spice-gtk-3.0 vala bindings https://bugs.freedesktop.org/show_bug.cgi?id=44000
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9825349..f3a84be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,7 +58,14 @@ BUILT_SOURCES = $(top_srcdir)/.version
$(top_srcdir)/.version:
echo $(VERSION) > $@-t && mv $@-t $@
-DISTCHECK_CONFIGURE_FLAGS = --enable-introspection --enable-werror --enable-gtk-doc
+DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-introspection \
+ --disable-vala \
+ --disable-usbredir \
+ --enable-gtk-doc \
+ --enable-werror \
+ --with-gtk=3.0 \
+ $(NULL)
spicy-for-windows.exe:
PATH=$$PATH:/usr/i686-pc-mingw32/sys-root/mingw/bin/:/usr/i686-pc-mingw32/sys-root/mingw/lib \