summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Gilbert <bgilbert@cs.cmu.edu>2015-02-04 03:46:48 -0500
committerMarc-André Lureau <marcandre.lureau@redhat.com>2015-02-06 17:18:27 +0100
commit08101d0146fe6d46e332ceacd66881a4c58fcf4c (patch)
treed87c7e6a223392970ca3b30872dc1ef2270f02f6 /Makefile.am
parent6631e262a1afe54b3ff1ee64b3f30c9a4b761c9d (diff)
downloadspice-gtk-08101d0146fe6d46e332ceacd66881a4c58fcf4c.tar.gz
spice-gtk-08101d0146fe6d46e332ceacd66881a4c58fcf4c.tar.xz
spice-gtk-08101d0146fe6d46e332ceacd66881a4c58fcf4c.zip
Don't build libspice-client-gtk if configured --without-gtk
libspice-client-glib is useful as a client library on platforms that don't support GTK.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8ac2028..e559c4d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,9 +16,12 @@ endif
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = \
spice-client-glib-2.0.pc \
- spice-client-gtk-$(SPICE_GTK_API_VERSION).pc \
$(NULL)
+if WITH_GTK
+pkgconfig_DATA += spice-client-gtk-$(SPICE_GTK_API_VERSION).pc
+endif
+
if WITH_CONTROLLER
pkgconfig_DATA += spice-controller.pc
endif