summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2013-09-26 19:03:25 +0200
committerMarc-André Lureau <marcandre.lureau@gmail.com>2013-09-26 19:03:31 +0200
commitf88e851ed684f25d325e610b3ac2db2d6bc30848 (patch)
treea1caab995598644756e8e4368fd9a2297932bfea /configure.ac
parent3363fe79f9d450774dd018a794c0b4381c1ef0a7 (diff)
downloadspice-common-f88e851ed684f25d325e610b3ac2db2d6bc30848.tar.gz
spice-common-f88e851ed684f25d325e610b3ac2db2d6bc30848.tar.xz
spice-common-f88e851ed684f25d325e610b3ac2db2d6bc30848.zip
build-sys: add --enable-smartcard=auto
Use same implementation as spice-gtk, to avoid need to explicitely set smartcard support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 14 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index b5cb960..acb7626 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,18 +34,22 @@ PKG_CHECK_MODULES(PIXMAN, pixman-1 >= 0.17.7)
AC_SUBST(PIXMAN_CFLAGS)
AC_ARG_ENABLE([smartcard],
- AS_HELP_STRING([--enable-smartcard=@<:@yes/no@:>@],
- [Enable smartcard support @<:@default=yes@:>@]),
+ AS_HELP_STRING([--enable-smartcard=@<:@yes/no/auto@:>@],
+ [Enable smartcard support @<:@default=auto@:>@]),
[],
- [enable_smartcard="yes"])
-
-if test "x$enable_smartcard" = "xno"; then
- AM_CONDITIONAL(WITH_SMARTCARD, false)
-else
- PKG_CHECK_MODULES(SMARTCARD, libcacard >= 0.1.2)
- AC_DEFINE(USE_SMARTCARD, [1], [Define if supporting smartcard proxying])
- AM_CONDITIONAL(WITH_SMARTCARD, true)
+ [enable_smartcard="auto"])
+
+have_smartcard=no
+if test "x$enable_smartcard" != "xno"; then
+ PKG_CHECK_MODULES(SMARTCARD, libcacard >= 0.1.2, [have_smartcard=yes], [have_smartcard=no])
+ if test "x$enable_smartcard" != "xauto" && test "x$have_smartcard" = "xno"; then
+ AC_MSG_ERROR("Smartcard support requested but libcacard could not be found")
+ fi
+ if test "x$have_smartcard" = "xyes"; then
+ AC_DEFINE(USE_SMARTCARD, [1], [Define if supporting smartcard proxying])
+ fi
fi
+AM_CONDITIONAL([WITH_SMARTCARD], [test "x$have_smartcard" = "xyes"])
AC_ARG_ENABLE([opengl],
AS_HELP_STRING([--enable-opengl=@<:@yes/no@:>@],