summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2015-07-06 17:57:52 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2015-08-11 10:26:06 +0200
commitf88a7b7bec4da8dcb648baee70a9e01fc0572197 (patch)
treecbb7ab7451b788cb68a597a834aab522319f991b /configure.ac
parentc48b0a0672ccfbdfc67dc4a29eff97a57989f786 (diff)
downloadspice-common-f88a7b7bec4da8dcb648baee70a9e01fc0572197.tar.gz
spice-common-f88a7b7bec4da8dcb648baee70a9e01fc0572197.tar.xz
spice-common-f88a7b7bec4da8dcb648baee70a9e01fc0572197.zip
Use installed spice-protocol for code generation
Now that spice-protocol ships the needed .proto files as well as the corresponding python scripts, spice-common can use these in order to generate the C code for the SPICE (de)marshallers.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1dacfa2..bc7ace2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,7 +28,9 @@ AM_PROG_CC_C_O
SPICE_CHECK_SYSDEPS
# Checks for libraries
-PKG_CHECK_MODULES([PROTOCOL], [spice-protocol])
+PKG_CHECK_MODULES([PROTOCOL], [spice-protocol >= 0.12.10])
+CODE_GENERATOR_BASEDIR=`pkg-config --variable=codegendir spice-protocol`
+AC_SUBST([CODE_GENERATOR_BASEDIR])
SPICE_CHECK_PYTHON_MODULES()