summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2014-12-02 11:00:20 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2014-12-09 16:37:21 +0100
commitdf74a17238e376b00cbafe7a48e8e4b406095755 (patch)
tree489e6cf894f01fd46fd4557d852543523dd81657 /configure.ac
parent2f1ba3b77f07f23ebbf0ad576985613331e4c3e4 (diff)
downloadspice-common-df74a17238e376b00cbafe7a48e8e4b406095755.tar.gz
spice-common-df74a17238e376b00cbafe7a48e8e4b406095755.tar.xz
spice-common-df74a17238e376b00cbafe7a48e8e4b406095755.zip
build-sys: Move posix checks to a separate m4 macro
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 2 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index a58fcd6..67e485e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,8 @@ if test "x$ac_cv_prog_cc_c99" = xno; then
fi
AM_PROG_CC_C_O
+SPICE_CHECK_SYSDEPS
+
# Checks for libraries
AC_CONFIG_SUBDIRS([spice-protocol])
PROTOCOL_CFLAGS='-I ${top_srcdir}/spice-protocol'
@@ -94,29 +96,6 @@ fi
AC_SUBST(GL_CFLAGS)
AC_SUBST(GL_LIBS)
-# Checks for header files
-AC_FUNC_ALLOCA
-AC_CHECK_HEADERS([arpa/inet.h malloc.h netinet/in.h stddef.h stdint.h stdlib.h string.h sys/socket.h unistd.h])
-
-# Checks for typedefs, structures, and compiler characteristics
-AC_C_INLINE
-AC_TYPE_INT16_T
-AC_TYPE_INT32_T
-AC_TYPE_INT64_T
-AC_TYPE_INT8_T
-AC_TYPE_PID_T
-AC_TYPE_SIZE_T
-AC_TYPE_UINT16_T
-AC_TYPE_UINT32_T
-AC_TYPE_UINT64_T
-AC_TYPE_UINT8_T
-
-# Checks for library functions
-# do not check malloc or realloc, since that cannot be cross-compiled checked
-AC_FUNC_ERROR_AT_LINE
-AC_FUNC_FORK
-AC_CHECK_FUNCS([dup2 floor inet_ntoa memmove memset pow sqrt])
-
# The End!
AC_CONFIG_FILES([
Makefile