summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2015-04-13 13:05:44 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2015-04-13 13:08:11 +0200
commit838ec7d87b5311843a7214fe946471fadd5d8908 (patch)
tree1bdeb7f7e2f59b32dc4339b93b0ab73c74def461 /configure.ac
parentc6e6dacb30b8130a069d522054718d757eefa0db (diff)
downloadspice-common-838ec7d87b5311843a7214fe946471fadd5d8908.tar.gz
spice-common-838ec7d87b5311843a7214fe946471fadd5d8908.tar.xz
spice-common-838ec7d87b5311843a7214fe946471fadd5d8908.zip
configure.ac: Check for needed python modules for git builds
After the patch adding support for python 3 to the code generator, python-six is required when building from git. Since I got 2 different reports of SPICE build failures right after introducing it, it's probably better to check for the needed python modules from configure, and exit with an error if they are missing. This commit adds a --enable-python-checks configure flag for that though, since we only want to do that when building from git. It assumes that people running from git will be running autogen.sh, while people building from tarballs will run configure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 73102c0..3a8c0e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,8 @@ AC_CONFIG_SUBDIRS([spice-protocol])
PROTOCOL_CFLAGS='-I ${top_srcdir}/spice-protocol'
AC_SUBST(PROTOCOL_CFLAGS)
+SPICE_CHECK_PYTHON_MODULES()
+
SPICE_CHECK_PIXMAN(SPICE_COMMON)
SPICE_CHECK_SMARTCARD(SPICE_COMMON)
SPICE_CHECK_CELT051(SPICE_COMMON)