summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy White <jwhite@codeweavers.com>2013-11-30 09:18:48 -0600
committerChristophe Fergeau <cfergeau@redhat.com>2014-01-02 12:28:21 +0100
commit57ce430ccd66bd1ca2447c14503234cfb88e2365 (patch)
tree5313ea2013ceeb1f281ed70d90aae41bf5ade505 /configure.ac
parentc108e4ee8cb33218d9a64e25de9e79b63d23a8e7 (diff)
downloadspice-common-57ce430ccd66bd1ca2447c14503234cfb88e2365.tar.gz
spice-common-57ce430ccd66bd1ca2447c14503234cfb88e2365.tar.xz
spice-common-57ce430ccd66bd1ca2447c14503234cfb88e2365.zip
Add support for the Opus codec.
Signed-off-by: Jeremy White <jwhite@codeweavers.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3443334..273d935 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,6 +67,10 @@ fi
AM_CONDITIONAL([HAVE_CELT051], [test "x$have_celt051" = "xyes"])
AM_COND_IF([HAVE_CELT051], AC_DEFINE([HAVE_CELT051], 1, [Define if we have celt051 codec]))
+PKG_CHECK_MODULES([OPUS], [opus >= 0.9.14], have_opus=yes, have_opus=no)
+AM_CONDITIONAL([HAVE_OPUS], [test "x$have_opus" = "xyes"])
+AM_COND_IF([HAVE_OPUS], AC_DEFINE([HAVE_OPUS], 1, [Define if we have Opus]))
+
AC_ARG_ENABLE([opengl],
AS_HELP_STRING([--enable-opengl=@<:@yes/no@:>@],
[Enable opengl support (not recommended) @<:@default=no@:>@]),