summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2012-12-06 15:13:33 +0100
committerPaolo Bonzini <pbonzini@redhat.com>2012-12-06 20:30:34 +0100
commit52d99b2dc68deffe9206d3d38b535e13867b8317 (patch)
tree39a0ab2fbc37819bd95e094f0e5571b350abeb57 /tests/Makefile.am
parentf5ea2b3e225db1e1da80d10defd11ee3a0266f39 (diff)
downloadmsitools-52d99b2dc68deffe9206d3d38b535e13867b8317.tar.gz
msitools-52d99b2dc68deffe9206d3d38b535e13867b8317.tar.xz
msitools-52d99b2dc68deffe9206d3d38b535e13867b8317.zip
port testrecord to non-Windows
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index fac5a89..9578852 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,12 +1,16 @@
AM_CPPFLAGS = -I$(top_srcdir)/include -I$(srcdir) -I.
+check_PROGRAMS = testrecord
+testrecord_SOURCES = testrecord.c
+testrecord_LDADD = ../libmsi/libmsi.la
+
+TESTS_ENVIRONMENT = srcdir=$(srcdir) ./runtest
+
if WIN32
-check_PROGRAMS = testdatabase testrecord testsuminfo
+check_PROGRAMS += testdatabase testrecord testsuminfo
testdatabase_SOURCES = testdatabase.c
testdatabase_LDADD = ../libmsi/libmsi.la -lole32
-testrecord_SOURCES = testrecord.c
-testrecord_LDADD = ../libmsi/libmsi.la -lole32
testsuminfo_SOURCES = testsuminfo.c
testsuminfo_LDADD = ../libmsi/libmsi.la -lole32
@@ -15,7 +19,6 @@ TESTS = \
testrecord$(EXEEXT) \
testsuminfo$(EXEEXT)
-TESTS_ENVIRONMENT = srcdir=$(srcdir) ./runtest
endif
CLEANFILES = \