summaryrefslogtreecommitdiffstats
path: root/libmsi/Makefile.am
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2012-12-05 08:56:06 +0100
committerPaolo Bonzini <pbonzini@redhat.com>2012-12-06 20:30:34 +0100
commit175346aac4942eb97ccf2f00ca127cf700cd2eff (patch)
tree788101151eeaa13fda5958086525fd7a8ff75e1b /libmsi/Makefile.am
parent91797cca0271709a2b491bb7ea36f9ff8d0da83e (diff)
downloadmsitools-175346aac4942eb97ccf2f00ca127cf700cd2eff.tar.gz
msitools-175346aac4942eb97ccf2f00ca127cf700cd2eff.tar.xz
msitools-175346aac4942eb97ccf2f00ca127cf700cd2eff.zip
port to libgsf
status: - record+suminfo pass - the following tests fail in testdatabase: try_transform, stringtable, deleterow, storages_table, createtable. Some of these are not enabled on POSIX systems, but the others pass there. TODO: port the missing tests to libgsf, run them against the IStorage version and again with the new one. verify that the testsuite passes on POSIX systems.
Diffstat (limited to 'libmsi/Makefile.am')
-rw-r--r--libmsi/Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/libmsi/Makefile.am b/libmsi/Makefile.am
index b336304..a7bccde 100644
--- a/libmsi/Makefile.am
+++ b/libmsi/Makefile.am
@@ -23,8 +23,4 @@ libmsi_la_SOURCES = alter.c create.c database.c delete.c distinct.c \
libmsi_la_LDFLAGS = -no-undefined -rpath $(libdir) \
-export-symbols-regex='^libmsi_'
-libmsi_la_LIBADD = \
- $(GLIB_LIBS) \
- $(GSF_LIBS) \
- -lshlwapi \
- -lole32
+libmsi_la_LIBADD = $(GLIB_LIBS) $(GSF_LIBS)