summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2013-01-16 12:51:24 +0100
committerPaolo Bonzini <pbonzini@redhat.com>2013-01-16 12:51:24 +0100
commitc1348bba1462be9dd93c5d12328473c1dc87889d (patch)
tree8b14edaedb4c67126c72e0dbeb8283edbb3bc4b6 /Makefile.am
parent2fba9f257a39cc485701358a35eb11d526e3799a (diff)
downloadmsitools-c1348bba1462be9dd93c5d12328473c1dc87889d.tar.gz
msitools-c1348bba1462be9dd93c5d12328473c1dc87889d.tar.xz
msitools-c1348bba1462be9dd93c5d12328473c1dc87889d.zip
dist: use autom4te to distribute test files
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f8dd3cc..5071300 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -113,6 +113,17 @@ installcheck-local: $(srcdir)/tests/testsuite atconfig atlocal
clean-local:
-$(SHELL) $(srcdir)/tests/testsuite --clean
+dist-hook:
+ @for file in `cd $(srcdir)/tests && \
+ $(AUTOM4TE) --language=autotest --trace='AT_MSIDATA:tests/data/$$1' \
+ testsuite.at`; do \
+ dir=`echo "/$$file" | sed -e 's,/[^/]*$$,,'`; \
+ $(MKDIR_P) "$(distdir)$$dir" || exit 1; \
+ echo cp -fpR $(srcdir)/$$file "$(distdir)$$dir"; \
+ cp -fpR $(srcdir)/$$file "$(distdir)$$dir" || exit 1; \
+ done
+
+
$(srcdir)/tests/testsuite: tests/testsuite.at tests/wixl.at tests/package.m4
cd $(srcdir)/tests && \
$(AUTOM4TE) --language=autotest -o testsuite.tmp testsuite.at && \