summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2012-12-07 08:44:25 +0100
committerPaolo Bonzini <pbonzini@redhat.com>2012-12-07 10:46:05 +0100
commit78b2f1aca29f6f670ae1e18631d1a6c391e5792d (patch)
tree23cce5df702c748b9221faa865959bdd1f61adef /Makefile.am
parent63ab32635aac24e6a8fd78598f60b56f31987e4a (diff)
downloadmsitools-78b2f1aca29f6f670ae1e18631d1a6c391e5792d.tar.gz
msitools-78b2f1aca29f6f670ae1e18631d1a6c391e5792d.tar.xz
msitools-78b2f1aca29f6f670ae1e18631d1a6c391e5792d.zip
convert testsuite to autotest
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 7 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 3456b5a..bb2516e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = libmsi . tests
+SUBDIRS = libmsi tests .
noinst_HEADERS = include/debug.h
dist_include_HEADERS = include/libmsi.h
@@ -21,22 +21,19 @@ msiinfo_DEPENDENCIES = libmsi/libmsi.la
# Autotest support
dist_noinst_DATA = tests/testsuite.at tests/package.m4 tests/testsuite
-DISTCLEANFILES = atconfig
+DISTCLEANFILES = atconfig atlocal
CLEANFILES = testsuite.log
-check-local: tests/testsuite atconfig
- builddir=`pwd` && \
- cd $(srcdir)/tests && \
- $(SHELL) testsuite AUTOTEST_PATH=$$builddir $(TESTSUITEFLAGS)
+check-local: $(srcdir)/tests/testsuite atconfig atlocal
+ $(SHELL) $(srcdir)/tests/testsuite AUTOTEST_PATH=. $(TESTSUITEFLAGS)
-installcheck-local: tests/testsuite atconfig
- cd $(srcdir)/tests && \
- $(SHELL) testsuite AUTOTEST_PATH=$(bindir) $(TESTSUITEFLAGS)
+installcheck-local: $(srcdir)/tests/testsuite atconfig atlocal
+ $(SHELL) $(srcdir)/tests/testsuite AUTOTEST_PATH=$(bindir) $(TESTSUITEFLAGS)
clean-local:
-$(SHELL) tests/testsuite --clean
-tests/testsuite: tests/testsuite.at tests/package.m4
+$(srcdir)/tests/testsuite: tests/testsuite.at tests/package.m4
cd $(srcdir)/tests && \
$(AUTOM4TE) --language=autotest -o testsuite.tmp testsuite.at && \
mv testsuite.tmp testsuite