summaryrefslogtreecommitdiffstats
path: root/tests/pkd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/pkd/CMakeLists.txt')
-rw-r--r--tests/pkd/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/pkd/CMakeLists.txt b/tests/pkd/CMakeLists.txt
index d4389595..515dae10 100644
--- a/tests/pkd/CMakeLists.txt
+++ b/tests/pkd/CMakeLists.txt
@@ -1,6 +1,6 @@
project(pkd C)
-if (UNIX AND NOT WIN32)
+if (WITH_SERVER AND UNIX AND NOT WIN32)
include_directories(
${LIBSSH_PUBLIC_INCLUDE_DIRS}
@@ -32,4 +32,4 @@ set(pkd_libs
add_executable(pkd_hello ${pkd_hello_src})
target_link_libraries(pkd_hello ${pkd_libs})
-endif (UNIX AND NOT WIN32)
+endif (WITH_SERVER AND UNIX AND NOT WIN32)