summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2015-09-07 07:46:11 +0200
committerAndreas Schneider <asn@cryptomilk.org>2015-09-07 07:46:11 +0200
commit5b586fdfecbe12f3f8e69099d809ca96c7cb978e (patch)
tree8ee49721e6209c1189fe717a299c9c0eecaab904 /tests/CMakeLists.txt
parent2f193b5cbb0c57160d3c590140bc04befccfbb32 (diff)
downloadlibssh-5b586fdfecbe12f3f8e69099d809ca96c7cb978e.tar.gz
libssh-5b586fdfecbe12f3f8e69099d809ca96c7cb978e.tar.xz
libssh-5b586fdfecbe12f3f8e69099d809ca96c7cb978e.zip
cmake: Handle libssh threas library correctly
This should fix the build on Windows and would not install pkg files. Signed-off-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 3bbb3309..d87c9c2f 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -22,12 +22,12 @@ set(TORTURE_LINK_LIBRARIES
${LIBSSH_STATIC_LIBRARY}
${LIBSSH_LINK_LIBRARIES})
-if (Threads_FOUND)
+if (LIBSSH_THREADS)
set(TORTURE_LINK_LIBRARIES
${TORTURE_LINK_LIBRARIES}
${LIBSSH_THREADS_STATIC_LIBRARY}
${LIBSSH_THREADS_LINK_LIBRARIES})
-endif ()
+endif (LIBSSH_THREADS)
# create test library
add_library(${TORTURE_LIBRARY} STATIC cmdline.c torture.c)