summaryrefslogtreecommitdiffstats
path: root/specs/pki-core.spec
diff options
context:
space:
mode:
authorChristian Heimes <cheimes@redhat.com>2015-08-16 19:00:00 +0200
committerEndi S. Dewata <edewata@redhat.com>2016-04-02 07:05:46 +0200
commit8627174e5bcc03616ba2185503fc6b6a6cf87527 (patch)
treece77dd8d8e3652a36e1f3e06493b86c81f4b8343 /specs/pki-core.spec
parentea5bd7fa1fc21b87c07a233c66fbe51d7f3ab9c1 (diff)
downloadpki-8627174e5bcc03616ba2185503fc6b6a6cf87527.tar.gz
pki-8627174e5bcc03616ba2185503fc6b6a6cf87527.tar.xz
pki-8627174e5bcc03616ba2185503fc6b6a6cf87527.zip
Py3 modernization: libmodernize.fixes.fix_import
Enforce absolute imports or explicit relative imports. Python 3 no longer supports implicit relative imports, that is unqualified imports from a module's directory. In order to load a module from the same directory inside a package, use from . import module The future feature 'from __future__ import absolute_import' ensures that pki uses absolute imports on Python 2, too. See https://www.python.org/dev/peps/pep-0328/
Diffstat (limited to 'specs/pki-core.spec')
-rw-r--r--specs/pki-core.spec2
1 files changed, 1 insertions, 1 deletions
diff --git a/specs/pki-core.spec b/specs/pki-core.spec
index 0fb8e8407..50776a7f8 100644
--- a/specs/pki-core.spec
+++ b/specs/pki-core.spec
@@ -729,7 +729,7 @@ done
%if ! 0%{?rhel}
# Scanning the python code with pylint.
-sh ../pylint-build-scan.sh %{buildroot} `pwd`
+python ../pylint-build-scan.py rpm --prefix %{buildroot}
if [ $? -ne 0 ]; then
echo "pylint failed. RC: $?"
exit 1