summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorEndi S. Dewata <edewata@redhat.com>2016-02-24 22:22:10 +0100
committerAde Lee <alee@redhat.com>2016-02-26 13:12:14 -0500
commit935633c5ea9f2b5c4321d924af166367008ac4b3 (patch)
tree514fdf2533b8be3cc3fe7789a3736b294f6952ba /setup.py
parent1d58b883ff9d0056d89d74d30f1375ab12d01f03 (diff)
downloadpki-935633c5ea9f2b5c4321d924af166367008ac4b3.tar.gz
pki-935633c5ea9f2b5c4321d924af166367008ac4b3.tar.xz
pki-935633c5ea9f2b5c4321d924af166367008ac4b3.zip
Added Python wrapper for pki pkcs12-import.
A Python wrapper module has been added for the pki pkcs12-import command to provide a mechanism to implement a workaround for JSS import limitation. Additional fixes by cheimes have been merged into this patch: setup.py: We must track all sub-packages manually. pylint-build-scan.py: pylint confuses the 'pki' package with the 'pki' command. The workaround symlinks the command and analysis the command under its alternative name. https://fedorahosted.org/pki/ticket/1742
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 8b606fb81..a2cf6c348 100644
--- a/setup.py
+++ b/setup.py
@@ -59,6 +59,7 @@ setup(
},
packages=[
'pki',
+ 'pki.cli',
'pki.server',
'pki.server.cli',
'pki.server.deployment',