summaryrefslogtreecommitdiffstats
path: root/base/deploy/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi Sukma Dewata <edewata@redhat.com>2012-12-04 07:19:43 -0500
committerEndi Sukma Dewata <edewata@redhat.com>2012-12-04 13:15:18 -0500
commit952300522ab5aaa9343c96dde7d785727cadfd95 (patch)
treec312cdaf4443ba70d99d99a66de856766abb315e /base/deploy/CMakeLists.txt
parenta3f7d585fed02fb8b0adaf46228f23bf1275c596 (diff)
downloadpki-ticket-399-9.tar.gz
pki-ticket-399-9.tar.xz
pki-ticket-399-9.zip
Archiving default deployment configuration.ticket-399-9
The default deployment configuration has been renamed and moved to /etc/pki/default.cfg to make it more accessible to users. The pkispawn has been modified to archieve the default deployment configuration along with the user-provided configuration in the registry. The pkidestroy will now use both archived configuration files to ensure proper removal. Ticket #399
Diffstat (limited to 'base/deploy/CMakeLists.txt')
-rw-r--r--base/deploy/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/base/deploy/CMakeLists.txt b/base/deploy/CMakeLists.txt
index 3848bd499..d63176f1a 100644
--- a/base/deploy/CMakeLists.txt
+++ b/base/deploy/CMakeLists.txt
@@ -62,6 +62,13 @@ install(
${DATA_INSTALL_DIR}/deployment
)
+install(
+ DIRECTORY
+ etc/
+ DESTINATION
+ ${SYSCONF_INSTALL_DIR}/pki
+)
+
find_package(PythonInterp REQUIRED)
execute_process(
COMMAND