summaryrefslogtreecommitdiffstats
path: root/base/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi S. Dewata <edewata@redhat.com>2016-11-18 07:54:53 +0100
committerEndi S. Dewata <edewata@redhat.com>2016-11-18 17:16:26 +0100
commite1c87187b5e47e8e38b6bc91c105c92ea5069c59 (patch)
tree65168cae6532d463a7dee1ba55c7c3c5f4c50241 /base/CMakeLists.txt
parent36fa1c9f9298654aab65d12a84cbf8f1c0e3bd6b (diff)
downloadpki-e1c87187b5e47e8e38b6bc91c105c92ea5069c59.tar.gz
pki-e1c87187b5e47e8e38b6bc91c105c92ea5069c59.tar.xz
pki-e1c87187b5e47e8e38b6bc91c105c92ea5069c59.zip
Update PKCS12Util to use SLF4J.
The PKCS12Util class has been modified to use SLF4J logging framework. The CMake scripts has been modified to include SLF4J libraries in the classpath. The spec file has been modified to add SLF4J dependencies. https://fedorahosted.org/pki/ticket/195
Diffstat (limited to 'base/CMakeLists.txt')
-rw-r--r--base/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/base/CMakeLists.txt b/base/CMakeLists.txt
index bb156ba48..e29101cc8 100644
--- a/base/CMakeLists.txt
+++ b/base/CMakeLists.txt
@@ -1,5 +1,19 @@
project(base)
+find_file(SLF4J_API_JAR
+ NAMES
+ slf4j-api.jar
+ PATHS
+ /usr/share/java/slf4j
+)
+
+find_file(SLF4J_JDK14_JAR
+ NAMES
+ slf4j-jdk14.jar
+ PATHS
+ /usr/share/java/slf4j
+)
+
# The order is important!
if (APPLICATION_FLAVOR_PKI_CORE)