summaryrefslogtreecommitdiffstats
path: root/base/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi S. Dewata <edewata@redhat.com>2017-02-15 17:15:26 +0100
committerEndi S. Dewata <edewata@redhat.com>2017-02-15 22:56:09 +0100
commitbc4efe021439ae064621aa511a446de2f0b421fb (patch)
treefa285cef564019cb41e4697b7f29b7dd74163a96 /base/CMakeLists.txt
parent771dd66e6f41042452db14af26792cf86556cf0b (diff)
downloadpki-bc4efe021439ae064621aa511a446de2f0b421fb.tar.gz
pki-bc4efe021439ae064621aa511a446de2f0b421fb.tar.xz
pki-bc4efe021439ae064621aa511a446de2f0b421fb.zip
Cleaned up CMake scripts for Jackson libraries.
To avoid redundancy the code that finds Jackson libraries has been moved to the top level CMake script.
Diffstat (limited to 'base/CMakeLists.txt')
-rw-r--r--base/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/base/CMakeLists.txt b/base/CMakeLists.txt
index ef3189de8..92ebe4313 100644
--- a/base/CMakeLists.txt
+++ b/base/CMakeLists.txt
@@ -30,6 +30,20 @@ find_file(SLF4J_JDK14_JAR
/usr/share/java/slf4j
)
+find_file(JACKSON_CORE_JAR
+ NAMES
+ jackson-core-asl.jar
+ PATHS
+ /usr/share/java/jackson
+)
+
+find_file(JACKSON_MAPPER_JAR
+ NAMES
+ jackson-mapper-asl.jar
+ PATHS
+ /usr/share/java/jackson
+)
+
find_file(TOMCAT_API_JAR
NAMES
tomcat-api.jar