summaryrefslogtreecommitdiffstats
path: root/base/CMakeLists.txt
diff options
context:
space:
mode:
authorFraser Tweedale <ftweedal@redhat.com>2016-06-28 15:50:36 +1000
committerFraser Tweedale <ftweedal@redhat.com>2016-07-01 10:16:28 +1000
commit3fdc686c9a4bab492d50cef707beef1f5f043153 (patch)
tree0ca21a5e1105e4cad2949a6b7895b78738f7c777 /base/CMakeLists.txt
parent8e40b74dc5d314912c65722b4284cab0ffbffbcc (diff)
downloadpki-3fdc686c9a4bab492d50cef707beef1f5f043153.tar.gz
pki-3fdc686c9a4bab492d50cef707beef1f5f043153.tar.xz
pki-3fdc686c9a4bab492d50cef707beef1f5f043153.zip
Fix build on Fedora 25
Look for the right JAX-RS API JAR (it has moved in Fedora 25). Also remove a lot of redundant 'find_file' operations for this JAR. Fixes: https://fedorahosted.org/pki/ticket/2373
Diffstat (limited to 'base/CMakeLists.txt')
-rw-r--r--base/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/base/CMakeLists.txt b/base/CMakeLists.txt
index b9d5c7bac..bb156ba48 100644
--- a/base/CMakeLists.txt
+++ b/base/CMakeLists.txt
@@ -2,6 +2,16 @@ project(base)
# The order is important!
if (APPLICATION_FLAVOR_PKI_CORE)
+
+ find_file(JAXRS_API_JAR
+ NAMES
+ jaxrs-api.jar
+ jboss-jaxrs-2.0-api.jar
+ PATHS
+ ${RESTEASY_LIB}
+ /usr/share/java
+ )
+
add_subdirectory(test)
add_subdirectory(symkey)
add_subdirectory(util)