summaryrefslogtreecommitdiffstats
path: root/base/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi S. Dewata <edewata@redhat.com>2017-01-17 12:19:52 +0100
committerEndi S. Dewata <edewata@redhat.com>2017-03-28 00:37:55 +0200
commit18412763e4ec09f4892c2a7b502d72ebfd9fec2a (patch)
treee2360a5e9848c42c2d2ee7c1e5a3beb0155b63ea /base/CMakeLists.txt
parent8cf4c5fadd2d5a154c99430be9898f37163bdac7 (diff)
downloadpki-18412763e4ec09f4892c2a7b502d72ebfd9fec2a.tar.gz
pki-18412763e4ec09f4892c2a7b502d72ebfd9fec2a.tar.xz
pki-18412763e4ec09f4892c2a7b502d72ebfd9fec2a.zip
Added audit logs for SSL/TLS events.
The CMSStartServlet has been modified to register an SSL socket listener called PKIServerSocketListener to TomcatJSS. The PKIServerSocketListener will receive the alerts generated by SSL server sockets and generate ACCESS_SESSION_* audit logs. The CS.cfg for all subsystems have been modified to include ACCESS_SESSION_* audit events. https://pagure.io/dogtagpki/issue/2602 Change-Id: If7fb6c1b096ec8c68d1fd08f9132baf099816f11
Diffstat (limited to 'base/CMakeLists.txt')
-rw-r--r--base/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/base/CMakeLists.txt b/base/CMakeLists.txt
index 92ebe4313..d2ea9a555 100644
--- a/base/CMakeLists.txt
+++ b/base/CMakeLists.txt
@@ -72,6 +72,13 @@ find_file(TOMCAT_UTIL_SCAN_JAR
/usr/share/java/tomcat
)
+find_file(TOMCATJSS_JAR
+ NAMES
+ tomcatjss.jar
+ PATHS
+ /usr/share/java
+)
+
# The order is important!
if (APPLICATION_FLAVOR_PKI_CORE)