summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi S. Dewata <edewata@redhat.com>2013-11-25 12:43:03 -0500
committerEndi S. Dewata <edewata@redhat.com>2013-12-06 03:18:23 -0500
commit8f6de6fd339c156ce3aad13ad5d45b635d194f79 (patch)
tree3d1b97403808f88a87b9e75aa6afc8e7280e8f8b /CMakeLists.txt
parent3adfccf442916b1f91177097a1ad318d1a2e7838 (diff)
downloadpki-8f6de6fd339c156ce3aad13ad5d45b635d194f79.tar.gz
pki-8f6de6fd339c156ce3aad13ad5d45b635d194f79.tar.xz
pki-8f6de6fd339c156ce3aad13ad5d45b635d194f79.zip
Added option to build without server packages.
The build scripts have been modified to accept an optional parameter to build pki-core without the server packages.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7e679d06e..2748a51d1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,8 +14,8 @@ string(REGEX REPLACE "^([0-9]+).*" "\\1" APPLICATION_VERSION_MAJOR ${VERSION})
string(REGEX REPLACE "^[0-9]+\\.([0-9]+).*" "\\1" APPLICATION_VERSION_MINOR ${VERSION})
string(REGEX REPLACE "^[0-9]+\\.[0-9]+\\.([0-9]+).*" "\\1" APPLICATION_VERSION_PATCH ${VERSION})
-option(WITH_JAVADOC "Build with Javadoc" ON)
-option(BUILD_PKI_SELINUX "Build pki-selinux" OFF)
+option(WITH_JAVADOC "Build Javadoc" ON)
+option(WITH_SERVER "Build Server" ON)
if (BUILD_IPA_PKI_THEME)
set(APPLICATION_FLAVOR_IPA_PKI_THEME TRUE)