summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Harmsen <mharmsen@redhat.com>2014-09-02 16:40:56 -0700
committerMatthew Harmsen <mharmsen@redhat.com>2014-09-02 16:40:56 -0700
commit5f863998006bc5521b1ad91e106b10cd3e748ad2 (patch)
tree2ac7e64c577bafcfcc556aaa542013e1343a9457 /CMakeLists.txt
parentc99069dac15a8c82e45e21747e94703c72c2a383 (diff)
downloadpki-5f863998006bc5521b1ad91e106b10cd3e748ad2.tar.gz
pki-5f863998006bc5521b1ad91e106b10cd3e748ad2.tar.xz
pki-5f863998006bc5521b1ad91e106b10cd3e748ad2.zip
Integrate 'tpsclient' back into primary TPS package
- PKI TRAC Ticket #1017 - Rename pki-tps-tomcat to pki-tps
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 5 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3eca8edfe..a0862c470 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,8 +25,6 @@ elseif (BUILD_REDHAT_PKI_THEME)
set(APPLICATION_FLAVOR_REDHAT_PKI_THEME TRUE)
elseif (BUILD_PKI_CORE)
set(APPLICATION_FLAVOR_PKI_CORE TRUE)
-elseif (BUILD_PKI_TPS)
- set(APPLICATION_FLAVOR_PKI_TPS TRUE)
elseif (BUILD_PKI_CONSOLE)
set(APPLICATION_FLAVOR_PKI_CONSOLE TRUE)
elseif (BUILD_PKI_MIGRATE)
@@ -58,9 +56,8 @@ include(Java)
file(MAKE_DIRECTORY ${CMAKE_BINARY_DIR}/classes)
file(MAKE_DIRECTORY ${CMAKE_BINARY_DIR}/dist)
-# required for all PKI components EXCEPT IPA_PKI_THEME and PKI_TPS
-if (NOT APPLICATION_FLAVOR_IPA_PKI_THEME AND
- NOT APPLICATION_FLAVOR_PKI_TPS)
+# required for all PKI components EXCEPT IPA_PKI_THEME
+if (NOT APPLICATION_FLAVOR_IPA_PKI_THEME)
include(JUnit)
add_custom_target(test)
@@ -79,7 +76,6 @@ endif ()
# ONLY required for Java-based PKI components
if (APPLICATION_FLAVOR_PKI_CORE OR
- APPLICATION_FLAVOR_PKI_TPS OR
APPLICATION_FLAVOR_PKI_CONSOLE OR
APPLICATION_FLAVOR_DOGTAG_PKI_THEME OR
APPLICATION_FLAVOR_PKI_MIGRATE)
@@ -87,14 +83,10 @@ if (APPLICATION_FLAVOR_PKI_CORE OR
find_package(JNI REQUIRED)
endif ()
-# ONLY required for PKI_CORE or PKI_TPS
-if (APPLICATION_FLAVOR_PKI_CORE OR
- APPLICATION_FLAVOR_PKI_TPS)
+# ONLY required for PKI_CORE
+if (APPLICATION_FLAVOR_PKI_CORE)
find_package(Ldap REQUIRED)
-endif ()
-
-# ONLY required for PKI_TPS
-if (APPLICATION_FLAVOR_PKI_TPS)
+ # required for native 'tpsclient' utility
find_package(APR REQUIRED)
find_package(Svrcore REQUIRED)
endif ()
@@ -154,7 +146,6 @@ add_custom_target(clean-cmake
# check subdirectories
if (APPLICATION_FLAVOR_PKI_CORE OR
- APPLICATION_FLAVOR_PKI_TPS OR
APPLICATION_FLAVOR_PKI_CONSOLE OR
APPLICATION_FLAVOR_PKI_MIGRATE)
add_subdirectory(base)