summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi S. Dewata <edewata@redhat.com>2015-02-24 21:02:13 -0500
committerEndi S. Dewata <edewata@redhat.com>2015-04-21 16:53:17 -0400
commit42667acb21cee0ce73c58aaf55aea8fee19620ff (patch)
tree6f3671276e1f76f4535e11cafd20542ab2bbe36e /CMakeLists.txt
parentab5f54371519010c72f4947901c3a76cb5105e41 (diff)
downloadpki-42667acb21cee0ce73c58aaf55aea8fee19620ff.tar.gz
pki-42667acb21cee0ce73c58aaf55aea8fee19620ff.tar.xz
pki-42667acb21cee0ce73c58aaf55aea8fee19620ff.zip
Added support for Tomcat 8.
The Dogtag code has been modified to support both Tomcat 7 and 8. All files depending on a specific Tomcat version are now stored in separate folders. The build scripts have been modified to use the proper folder for the target platform. The tomcatjss dependency has been updated as well. The upgrade script will be added in a separate patch. https://fedorahosted.org/pki/ticket/1264
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6702ac07d..12a7493b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,8 +14,10 @@ string(REGEX REPLACE "^([0-9]+).*" "\\1" APPLICATION_VERSION_MAJOR ${VERSION})
string(REGEX REPLACE "^[0-9]+\\.([0-9]+).*" "\\1" APPLICATION_VERSION_MINOR ${VERSION})
string(REGEX REPLACE "^[0-9]+\\.[0-9]+\\.([0-9]+).*" "\\1" APPLICATION_VERSION_PATCH ${VERSION})
-option(WITH_JAVADOC "Build Javadoc" ON)
+option(WITH_TOMCAT7 "Build Tomcat 7" ON)
+option(WITH_TOMCAT8 "Build Tomcat 8" ON)
option(WITH_SERVER "Build Server" ON)
+option(WITH_JAVADOC "Build Javadoc" ON)
if (BUILD_DOGTAG_PKI_THEME)
set(APPLICATION_FLAVOR_DOGTAG_PKI_THEME TRUE)