summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Harmsen <mharmsen@redhat.com>2012-11-08 18:13:58 -0800
committerEndi Sukma Dewata <edewata@redhat.com>2012-11-09 13:48:50 -0500
commit15c0c559b70e33694309fd2362605515aa33b0a3 (patch)
tree6adb8dc0479b3853b6260c3d781a73750e0c1a17
parent1e15712d2a6c45d2dd2ac64b3b76a757ca9de2e8 (diff)
downloadpki-ticket-398.zip
pki-ticket-398.tar.gz
pki-ticket-398.tar.xz
Move default location for client certificate databaseticket-398
* TRAC Ticket #395 - Dogtag 10: Add a Tomcat 7 runtime requirement to 'pki-server' * TRAC Ticket #398 - Move default location for client certificate database
-rw-r--r--base/deploy/src/scriptlets/pkiparser.py4
-rw-r--r--specs/pki-core.spec8
2 files changed, 9 insertions, 3 deletions
diff --git a/base/deploy/src/scriptlets/pkiparser.py b/base/deploy/src/scriptlets/pkiparser.py
index cdc3b5f..a108932 100644
--- a/base/deploy/src/scriptlets/pkiparser.py
+++ b/base/deploy/src/scriptlets/pkiparser.py
@@ -1368,9 +1368,9 @@ def compose_pki_master_dictionary():
if not len(config.pki_master_dict['pki_client_dir']):
config.pki_master_dict['pki_client_dir'] =\
os.path.join(
- "/tmp",
+ os.path.expanduser("~"), ".pki",
config.pki_master_dict['pki_instance_id'] + "_" +\
- config.pki_subsystem + "_" + "client")
+ config.pki_master_dict['pki_subsystem'].lower())
if not len(config.pki_master_dict['pki_client_database_dir']):
config.pki_master_dict['pki_client_database_dir'] =\
os.path.join(
diff --git a/specs/pki-core.spec b/specs/pki-core.spec
index 1b6cf74..4c0f2a7 100644
--- a/specs/pki-core.spec
+++ b/specs/pki-core.spec
@@ -14,7 +14,7 @@ distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
Name: pki-core
Version: 10.0.0
-Release: %{?relprefix}48%{?prerel}%{?dist}
+Release: %{?relprefix}49%{?prerel}%{?dist}
Summary: Certificate System - PKI Core Components
URL: http://pki.fedoraproject.org/
License: GPLv2
@@ -308,6 +308,7 @@ Requires: pki-tools = %{version}-%{release}
%if 0%{?fedora} >= 18
Requires: selinux-policy-base >= 3.11.1-43
Obsoletes: pki-selinux
+Requires: tomcat >= 7.0.27
%else
Requires: pki-selinux = %{version}-%{release}
%endif
@@ -317,6 +318,7 @@ Requires: velocity
Requires(post): systemd-units
Requires(preun): systemd-units
Requires(postun): systemd-units
+Requires: tomcat >= 7.0.27
Requires: tomcatjss >= 7.0.0-3
%else
%if 0%{?fedora} >= 16
@@ -1271,6 +1273,10 @@ fi
%changelog
+* Thu Nov 8 2012 Matthew Harmsen <mharmsen@redhat.com> 10.0.0-0.49.b2
+- TRAC Ticket #395 - Dogtag 10: Add a Tomcat 7 runtime requirement to
+ 'pki-server'
+
* Mon Oct 29 2012 Ade Lee <alee@redhat.com> 10.0.0-0.48.b2
- Update release to b2