summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNoriko Hosoi <nhosoi@redhat.com>2006-11-10 23:59:16 +0000
committerNoriko Hosoi <nhosoi@redhat.com>2006-11-10 23:59:16 +0000
commiteaae6c2543e43a9c46d823c9bd11e267507469ff (patch)
tree6a41c0c1b4aa31919749bd410f6b0aa152f1df79 /configure.ac
parent6679b0968981f8be7c33a7df2c30bb5146f3a6d3 (diff)
downloadds-eaae6c2543e43a9c46d823c9bd11e267507469ff.tar.gz
ds-eaae6c2543e43a9c46d823c9bd11e267507469ff.tar.xz
ds-eaae6c2543e43a9c46d823c9bd11e267507469ff.zip
Resolves: #214533
Summary: configure needs to support --with-fhs (Comment #1) Changes: 1. introduced a new option --with-fhs 2. instead of passing the define macro with -D, generate config.h
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aedf2ff5..f7e1f52f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,6 +2,8 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
AC_INIT([fedora-ds], [1.1], [http://bugzilla.redhat.com/])
+# AC_CONFIG_HEADER must be called right after AC_INIT.
+AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([1.9 foreign subdir-objects])
AM_MAINTAINER_MODE
AC_CANONICAL_HOST
@@ -94,6 +96,7 @@ m4_include(m4/sasl.m4)
m4_include(m4/svrcore.m4)
m4_include(m4/icu.m4)
m4_include(m4/netsnmp.m4)
+m4_include(m4/fhs.m4)
# write out paths for binary components
AC_SUBST(nspr_inc)
@@ -152,6 +155,9 @@ AC_SUBST(scripttemplatedir)
# cygnus, mingw, or the like and using cmd.exe as the shell
AM_CONDITIONAL([WINNT], false)
+AC_DEFINE([LDAP_DEBUG], [1], [LDAP debug flag])
+AC_DEFINE([LDAP_DONT_USE_SMARTHEAP], [1], [Don't use smartheap])
+
AC_CONFIG_FILES([Makefile])
AC_OUTPUT