summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNathan Kinder <nkinder@redhat.com>2007-02-16 23:25:06 +0000
committerNathan Kinder <nkinder@redhat.com>2007-02-16 23:25:06 +0000
commit47d5f680b42c229bdeef0be7fe8a046a7443a41b (patch)
tree2846d72c95d91d27b432a1d124c6f05a86bf168e /configure.ac
parent158fc7b78cd8e54be408a2ab9dd4542e6e703d0c (diff)
downloadds-47d5f680b42c229bdeef0be7fe8a046a7443a41b.tar.gz
ds-47d5f680b42c229bdeef0be7fe8a046a7443a41b.tar.xz
ds-47d5f680b42c229bdeef0be7fe8a046a7443a41b.zip
Resolves: 229095
Summary: Fixed build flags for compiling with pthread on HP-UX.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c1f78c96..c4fe3d47 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,6 +157,8 @@ case $host in
AC_DEFINE([HPUX11_23], [1], [HP-UX 11.23])
AC_DEFINE([CPU_ia64], [], [cpu type ia64])
AC_DEFINE([OS_hpux], [1], [OS HP-UX])
+ AC_DEFINE([_POSIX_C_SOURCE], [199506L], [POSIX revision])
+ AC_DEFINE([_HPUX_SOURCE], [1], [Source namespace])
platform="hpux"
;;
hppa*-hp-hpux*)
@@ -167,6 +169,8 @@ case $host in
AC_DEFINE([HPUX11_11], [1], [HP-UX 11.11])
AC_DEFINE([CPU_hppa], [], [cpu type pa-risc])
AC_DEFINE([OS_hpux], [1], [OS HP-UX])
+ AC_DEFINE([_POSIX_C_SOURCE], [199506L], [POSIX revision])
+ AC_DEFINE([_HPUX_SOURCE], [1], [Source namespace])
platform="hpux"
;;
sparc-sun-solaris*)
@@ -197,6 +201,7 @@ case $host in
esac
AC_SUBST(initdir)
+AM_CONDITIONAL(HPUX,test "$platform" = "hpux")
AM_CONDITIONAL(SOLARIS,test "$platform" = "solaris")
# Check for library dependencies