summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNathan Kinder <nkinder@brigittae.localdomain>2009-07-15 14:04:40 -0700
committerNathan Kinder <nkinder@boraras.localdomain>2009-07-15 16:17:33 -0700
commitf1b25be262ac07cd366814e4920a22f1852d737f (patch)
treed62d79bec882f3377bf088ed923569e5444ec159 /Makefile.am
parent842abb57c509e18a4b4b987a50e90f19d233cfcc (diff)
downloadds-f1b25be262ac07cd366814e4920a22f1852d737f.tar.gz
ds-f1b25be262ac07cd366814e4920a22f1852d737f.tar.xz
ds-f1b25be262ac07cd366814e4920a22f1852d737f.zip
Bug: 479753 - Update core schema
This patch updates and reorganizes our core schema to follow the most recently defined standards. The layout of the core schema files is as follows: 00core.ldif - RFC 4512, RFC 4519, LDAP Subentry Internet Draft 01core389.ldif - 389 specific schema (required to start server) 02common.ldif - 389 specific schema (highly recommended, Changelog Internet Draft, plug-in schema) 05rfc2927.ldif - MIME Directory Profile for LDAP Schema 05rfc4523.ldif - Schema Definitions for X.509 Certificates 05rfc4524.ldif - Cosine LDAP/X.500 Schema 06inetorgperson.ldif - RFC 2798 (pulls in RFC 2079 and part of the obsolete RFC 1274 due to required attributes) There are still a handful of syntaxes that we don't support, so I've substituted syntaxes for about 15 attributes. The schema and DIT related description syntaxes are not supported, so I've used the "Directory String" syntax instead in 00core.ldif. The certificate syntaxes defined in 4523 are not supported, so I've used the "Octet String" syntax instead. All of these deviations are commented with a "TODO" listing the syntax that we need to implement. I have also updated the Mozilla address book schema to the latest from upstream for a minor bug fix. I changed the nsSymmetricKey attribute to use the "Octet String" syntax since the "Binary" syntax is deprecated.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 65977d9d..05cb3566 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -218,13 +218,15 @@ sampledata_DATA = $(srcdir)/ldap/ldif/Ace.ldif \
$(LIBPRESENCE_SCHEMA)
schema_DATA = $(srcdir)/ldap/schema/00core.ldif \
- $(srcdir)/ldap/schema/01common.ldif \
- $(srcdir)/ldap/schema/05rfc2247.ldif \
+ $(srcdir)/ldap/schema/01core389.ldif \
+ $(srcdir)/ldap/schema/02common.ldif \
$(srcdir)/ldap/schema/05rfc2927.ldif \
+ $(srcdir)/ldap/schema/05rfc4523.ldif \
+ $(srcdir)/ldap/schema/05rfc4524.ldif \
+ $(srcdir)/ldap/schema/06inetorgperson.ldif \
$(srcdir)/ldap/schema/10rfc2307.ldif \
$(srcdir)/ldap/schema/20subscriber.ldif \
$(srcdir)/ldap/schema/25java-object.ldif \
- $(srcdir)/ldap/schema/28pilot.ldif \
$(srcdir)/ldap/schema/30ns-common.ldif \
$(srcdir)/ldap/schema/50ns-admin.ldif \
$(srcdir)/ldap/schema/50ns-certificate.ldif \